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Introduction 

The eMaRC (Electronic Mapping, Reporting  and Coding ) Plus software was initially developed for the 

NPCR- Advancing E-cancer Reporting and Registry Operations' ePath Project by the Registry Plus 

Development Team of the U.S. Centers for Disease Control and Prevention (CDC) in 2006. The eMaRC 

Plus ePath (electronic Pathology) Reporting Module reads HL7 version 2.3.1 and 2.5.1 Observation 

Result (ORU 01) message batch files, parses messages, and stores HL7 data elements as discrete field 

values into tables in the Pathlab database. In a typical setting, the Public Health Information Network 

Messaging System (PHINMS) is used to send securely HL7 batch files from a laboratory to a cancer 

registry or some other agency working on the cancer registry’s behalf. The eMaRC Plus resides at a 

cancer workstation and polls the worker queue of the PHINMS receiver for any new incoming files. 

When a new file arrives in the queue, the application selects it based on the text containing cancer 

terms, processes it, and then goes back in the waiting mode until another new file arrives. eMaRC Plus 

ePath Reporting Module can be used in an interactive mode where the user manually selects a file to 

import into the Pathlab database. 

During import, eMaRC Plus uses a terms table to search reports for potential cancer cases. Additionally, 

a built-in negation terms finder algorithm (NegEx) enhances the program’s text interpretation 

capabilities by discriminating the cancer term when used in a negative manner. For example, patient 

was determined not to have lymphoma, where lymphoma would be a cancer term searched for to 

include as a cancer related report. The program shows imported pathology reports in the user readable 

format with cancer terms highlighted in red and negated terms highlighted in blue. An administrator can 

customize both the terms table and the negation phrases table. 

eMaRC Plus also creates partial abstracts from HL7 version 2 messages during import, translating coded 

values from the HL7 coding standard to the North American Association of Central Cancer Registries 

(NAACCR) standards. It allows you to view pathology report data items from the HL7 message side-by-

side with abstract data items on the same screen. This allows you to look at the text of pathology 

reports and code data items, such as primary site and histology, in partial abstracts. The autocode 

histology feature suggests pertinent histology codes by analyzing the text of the report while the user 

codes abstracts. 

In June 2014, the CDC’s Cancer Surveillance Branch staff distributed the first production release of the 

Physician Reporting Module as part of the eMaRC Plus application. The Physician Reporting module 

imports HL7 Clinical Document Architecture (CDA) documents from physician office electronic health 

record (EHR) or electronic medical record (EMR) as part of Stage 2 and Stage 3 Meaningful Use. The 

documents can be imported manually or directly from a folder or the PHINMS queue, can be confirmed 

to include the required data items, parsed for the HL7 documents, mapped and, if needed, can have the 

HL7 data elements translated to NAACCR data elements. 
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Overview of User’s Guide 

Through this manual, users will be introduced to eMaRC Plus ePath Reporting Module functionalities 

and capabilities in a detailed, step by step manner. This manual provides information on tasks to be 

performed by Registrar Users. For information regarding Administrator functionality, please see 

document “Administrator’s Guide: eMaRC Plus” located on SharePoint. 

eMaRC Plus displays pathology reports in a Workbench view, creating a side-by-side view of the 

pathology report text with an automatically generated abstract to allow coding of primary site and 

histology. Some data fields in the abstract will be prepopulated based on the submitted pathology 

report, but users are allowed to override any automated decisions about reportability and coding. 

This manual presents the information required by users of the eMaRC Plus system. The following 

chapters of this manual cover the subjects that enable you to: 

➢ Log in to eMaRC Plus ePath Module. 

➢ Use the features of eMaRC Plus to work with reports received in either Health Level Seven 

International Standard (HL7) or pipe-delimited files by importing and processing batch files. 

➢ Use functions within eMaRC Plus to review pathology reports and create abstracts for exporting 

to the registry. 
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eMaRC Plus Features 

eMaRC Plus was developed to view and work with HL7 files. eMaRC Plus was developed collaboratively 

by participants in the National Program of Cancer Registries - Advancing E-cancer Reporting and Registry 

Operations' (NPCR-AERRO) ePath Pilot Project and programmed by the Registry Plus Development 

Team. 

The program includes functions to import HL7 files manually or directly from the PHINMS queue, test 

messages for existence of required data items, parse HL7 files, and map HL7 data elements to NAACCR 

data elements. eMaRC Plus also builds a pathology laboratory database, storing various HL7 data 

elements as discrete field values into tables in the database. The program creates NAACCR formatted 

abstract records from pathology reports during import into the pathology laboratory database. The 

program searches a terms table to find potential report of cancer, and uses a negation terms finder 

algorithm (NegEx) built in to enhance the program's text mining capabilities in terms of specificity. 

eMaRC Plus provides a view of the pathology report text and a generated abstract side-by-side allowing 

coding of primary site, histology, grade, behavior, and laterality. This allows the user to override any 

automated decisions about reportability and coding. 

System Requirements 

eMaRC Plus program works with 64-bit Microsoft® Windows® operating systems on x86-compatible 

processors. The minimum hardware requirements are the same as those of the Microsoft Windows 

operating system used. 

System requirements includes: 

➢ Minimum Processor 1GHz, but recommended Intel i5 with 1.9GHz or better processor. 

➢ Microsoft operating system Window 7, 8 and 10 or newer; Windows Server 2016 or newer.  

➢ Minimum of 2 GB, but recommended 4 GB (or more) memory for improved user experience. 

➢ Latest version of Microsoft Internet Explorer (recommended). 

➢ A minimum of 200 MB free hard drive space is required, which excludes eMaRC Plus database. 

➢ Microsoft .NET Framework Version 4.5 Full Version or newer version. 

➢ Application comes with a default Microsoft Local Database for configuration and low budget 

use.  For enterprise/production use, it must be reconfigured to work with SQL Server 2016 or 

newer version.  

It is highly recommended to use a professional grade database server to avoid data loss (a database 

hosted on separate server gives you a more reliable platform). It is strongly recommended to do a back-

up periodically. 

 

User Support 

For technical support via e-mail, contact cancerinformatics@cdc.gov. 

The CDC Registry Plus Development group is funded primarily to support NPCR-funded state central 

cancer registries.  As a result, CDC helps state central cancer registries set up the software and perform 

mailto:cancerinformatics@cdc.gov
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basic customizations. CDC also provides periodic software updates and problem solving to the extent 

available resources allow. CDC does not provide on-site services, and does not support hospitals, clinics, 

laboratories, or other private users. 

eMaRC Plus is intended for distribution to central cancer registries after as-needed customization by the 

central registry. The state central registry or other institution using Registry Plus software should 

provide all support to end users submitting data to the system.   

State registry contact information can be found at the National Program of Cancer Registries Web site: 

  https://nccd.cdc.gov/dcpc_Programs/index.aspx#/3. 

Other users of eMaRC Plus will need to independently understand and maintain the software 

application. 

  

https://nccd.cdc.gov/dcpc_Programs/index.aspx#/3
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Getting Started 

Launching eMaRC Plus 

Once installed, you can launch eMaRC Plus: 

1. From the Start menu, select All Programs – Registry Plus – eMaRC Plus, and then eMaRC Plus. 

  

Launching eMaRC Plus 

2. The Login dialog box appears for you to enter User ID and Password.  

• The eMaRC Plus log-in dialog box will open. 

• The Administrator now has an option to sign into the System Configuration from the initial 

login dialog box. 

  

eMaRC Login dialog box. 

 

3. Enter your eMaRC User name and Password and select ePath Reporting.  

 

NOTE: Please contact an eMaRC Administrator to set up a User name and password for 

your initial login. 
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Changing Your Password 

1. Select Administration>Manage User… 

• The Manage User dialog box appears. 

  

Manage User dialog box. 

2. Select your name from the list of users and click Change Password. 

• The Change Password dialog box opens. 

  

Change Password dialog box. 

3. Type in your new password in the Enter password field and retype your password in the Re-

enter password field. The passwords must match, including capitalization and use of special 

characters. 

NOTE: Users are only permitted to change their own passwords. Only an eMaRC 

Administrator can reset the password of another user. 

4. Click Ok. 
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eMaRC Plus Main Window 

When a user successfully logs in to eMaRC Plus, the main window will open.  

  

eMaRC Plus main window. 

 

The Menu Bar 

The menu bar contains the following options:  

  

eMaRC Plus menu bar. 

 

File 

Contains options commonly performed by users assigned a role of “Registrar” in eMaRC Plus. 

  

eMaRC Plus File menu. 
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Administration 

Many of the options and functionalities in the Administration menu can only be performed when a user 

is assigned an “Administrator” role in eMaRC Plus.  

  

eMaRC Plus Administration menu. 

NOTE: Please see the Administrator Guide for eMaRC Plus located on SharePoint for more details 

on functionalities available in the Administration menu options. 

Tools 

Contains the Bookmark options, which allows a user to save their spot and easily navigate back to a 

report of interest. 

   

eMaRC Plus Tool menu. 

For more details on bookmarking reports, please see the Bookmark Reports section. 
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Help 

Provides access to the online help system and a dialog box that displays the eMaRC Plus version.  

 

eMaRC Plus Help menu. 

• User’s Manual: Opens the online User’s Manual for eMaRC Plus. 

• Administrator’s Manual: Opens the online Administrator’s Manual for eMaRC Plus. 

• About: Opens the About dialog box to view the current version of eMaRC Plus. 

The Tool Bar 

The Tool Bar contains shortcuts for commonly used eMaRC features. Many of the Tool Bar options can 

also be found under the File menu. 

 

eMaRC Plus Tool Bar. 

The Tool Bar contains the following options:  

• Import HL7 – same as the File menu Import Files Manually>HL7 ORU Message Format… option. 

 See Manually Import HL7 Messages section for more details. 

• Import Pipe-delimited – same as the File menu Import Files Manually>Pipe Delimited Format… 

option. 

 See Import Pipe-delimited section for more details. 

• Open Batch – same as File menu Open Pathology Reports Batch… option. 

 See Open Batch View section for more details. 

• Export Abstracts – same as File menu Export Abstracts… option. 

 See Export Abstracts and HL7 Messages section for more details 

• PHINMS Queue – same as File menu PHINMS Queue… option. 

• Search – same as the File menu Search for Pathology Reports… option. 

 See Searching for Pathology Reports section for more details. 

• Show/Hide List – use with Workbench dialog box to show/hide the Search/Filter/List Reports pane. 

 See Filter/Search/Report List section for more details. 

• Raw Data – displays the unformatted text of an HL7 ORU message that is open in the Pathology 

Report Workbench. 
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 See Raw Data Button section for more details. 

• Reports – runs reports on eMaRC pathology data and provides output in a .csv file. 

 See Reports Button section for more details.  
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Importing Pathology Reports 

Import HL7 Messages via HL7 Interface 

Pathology reports are received via the HL7 Interface, where they are grouped into batches and queued. 

To import reports into eMaRC Plus via the HL7 Interface: 

PHINMS Queue 

1. Select File>Poll and Import HL7 Batch File from PHINMS Queue. 

 

eMaRC Plus File menu option Poll and Import HL7 Batch File from PHINMS Queue. 

 

• Reports will begin to import. Progress of the import is shown in the Import dialog box. 

 

Import dialog box. 

 

NOTE: Performance may be slower in the eMaRC application during import of batches. 
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2. When reports have finished importing, click the Abort button in the dialog box to close the 

Polled Import. 

 

Polled Import dialog box.  

When the import is complete, new batches will be created containing the imported messages. 

 

Folder Poll 

1. Select File>Poll and Import HL7 Batch File from Folder. 

  

eMaRC Plus File menu option Poll and Import HL7 Batch File from Folder.  

• A Browse for Folder box will appear, select the correct folder and proceed. 

 

Manually Import HL7 Messages 

Messages are usually loaded automatically from the inbound HL7 interface.  However, it may at some 

point become necessary to load manually Pathology Reports from an HL7 file. 

 

NOTE: privacy and security policies require that any HL7 files containing PHI be stored on a 

secure drive. 
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1. Select Import HL7 from the main eMaRC Tool Bar. 

 

eMaRC Plus Tool Bar option Import HL7. 

• The Open dialog box opens. 

 

2. Navigate to the file location of the HL7 message and click Open. 

 

• Reports will begin to import. Progress of the import is shown in the Import dialog box. 

When the import is complete, a new batch will be created containing the imported messages. 
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Importing Pipe-delimited Pathology Reports 

Import Pipe-delimited Messages via HL7 Interface 

Pathology reports are received via the HL7 Interface, where they are grouped into batches and queued. 

To import reports into eMaRC Plus via the HL7 Interface: 

1. Select File>Import Pathology Report Manually>Pipe-delimited Format or select the Import              

Pipe-delimited button from the main workbench dialog box. 

  

eMaRC Plus File menu option Import Pathology Reports Manually, Pipe-delimited Format  

 

 

Main Workbench Dialog Box, Import Pipe-delimited  

 

The flowing Import Piped Delimited File dialog box appears. 

  

Import Pipe-delimited File box 

 

2. Set the date format in the Select date format in the file: field. There are two formats for date:           

YYYYMMDD and MMDDYYYY where Y – Year, M – Month and D – Day 

 

3. Click the Browse… button. Result: the Open dialog box appears.  
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4. Select a file from the list in the Open dialog box and click the Open button. Result: the Import 

dialog box appears and displays the progress of the batch file being scanned and opened. 

 

Import dialog box – Pipe-delimited File  
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Add Path Reports Manually 

Add Path Report Manually 

Pathology reports that are not received via the HL7 Interface can be manually added; paper copies’ or 

sent via secure transport can be converted and or scanned and saved as a PDF. Each path report will 

need to be done individually and saved on a secure drive. 

1. Select File>Add Path Report Manually> button from the main workbench dialog box. 

 

eMaRC Plus File option Add Path Report Manually 

2. Select Add>Browse and Select PDF File… 

• Selected file will appear in Attachments Window 

  

Add Path Report Manually Display  
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3. Select the file located in Attachments; manually abstract data from the pathology report and 

select save.  

 

Add Path Report Manually Lab and Abstract Display 

• To remove a file selected the file located in the Attachments window and select Remove 

  



  

User Guide: 

eMaRC Plus v9.0 

Page 22 of 57 
 

 

Open Pathology Reports 

There are two ways to open Pathology Reports for viewing in eMaRC: 

• Open Batch 

• Search 

Open Batch View 

One way to view the Pathology Reports stored in eMaRC is to use the Open Batch option. 

1. In the main window, click the Open Batch button. 

 

eMaRC Plus Tool Bar option Open Batch. 

 

• The Pathology Reports Batches window opens. Imported HL7 batches and Pipe-delimited 

batches will be listed here. 

 

NOTE: Only the last 100 reports are displayed by default in the Open Batch view. The 

user has the option to select to view complete, review, specify number of batches, select 

an import range, and select a batch range or to show all. Select choice and click Apply 

Filter. 

 

 

 

Pathology Reports Batches window. 

The following information is displayed for each batch: 

• Batch ID: the eMaRC Plus assigned number for the batch file.  

• Filename: the filename of the batch file.  

• Lab: the pathology lab that created the batch file.  
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• Import Date/Time: the date and time the batch file was loaded into eMaRC Plus.  

• Status: the current status of the batch file (Review, Complete).  

• User: the user assigned (three character ID) to the batch file or None.  

• # Reports: the number of reports contained in the batch file.  

• # Review: the number of reports in the batch file with a Review status. 

• # Hold: the number of reports of the batch file with a status of Hold.  

• #Followback: the number of reports of the batch file with a status of Followback. 

• # Complete: the number of reports in the batch file that have completed (saved) abstracts.  

• # No cancer terms: the number of reports that eMaRC Plus has determined that contain no 

cancer terms.  

• # Non-reportable: the number of reports that have a status of non-reportable in the 

selected batch file.  

• # Exported: the number of reports that have been exported in the selected batch file. 

• Type: the type of batch file (HL7 ORU^1 or Pipe-delimited).  

 

2. To view a report, double click on the batch you would like to open or highlight a batch click the 

Open selected batch… button at the bottom left corner after selecting a batch.  

  

Open Selected Batch option. 

NOTE: Batches are sorted by Batch ID by default. To order batches by another column, 

click the column label. 

3. Click the Refresh button in the upper right corner to: 

• Show any new batches in the Open Batch display. 

• Recalculate the reports listed in the Reports columns (# Reports, # Review, # Hold, # 

Followback,  # Complete, # No cancer terms and # Non-reportable). 

 

Refresh button option. 

4. To view any errors encountered during import, select a batch from the Open Batch window and 

click Show Import Errors… button at the bottom left corner after selecting a batch. 

  

Show Import Error option. 

5. To Export Open Batch Screen to Excel, select a batch from the Open Batch window and click 

Export to Excel… button at the bottom left corner after selecting a batch. 



  

User Guide: 

eMaRC Plus v9.0 

Page 24 of 57 
 

  

 

 

Open Batch Settings 

An eMaRC User has the ability to modify the default Open Batch view to adjust the number of reports 

and status of reports visible. 

1. Click Open Batch tab… 

• The Open Batch dialog box opens.  

  

 

Application Configuration dialog box – Import Setting tab. 

2. By default, only the last 100 batches are shown. The user can choose one of the following 

options; 

• Complete: select this check box and click Apply Filter to view batches with zero reports for 

review. 

• Review: select this check box and click Apply Filter to view batches that need review. 

• Last & Batches: check the last box and indicate in the batches box the number of batches 

to review, click Apply Filter. 

• Import Date Range: select a date range of batches and click Apply Filter. 

• Batch ID Between: select a range of batches by ID and Apply Filter. 

 

Searching for Pathology Reports 

A second way to view the Pathology Reports stored in eMaRC is to use the Search option. The search 

functionality allows you to search for all reports across all batches. 

 

1. Click Search in the eMaRC Tool Bar. 

 

 

eMaRC Plus Tool Bar option Search. 
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• The following Search Window will appear. 

  

eMaRC Search Window. 

2. Enter your search criteria in one or more of the following tabs: 

• Patient 

• Facility 

• Disease 

• Report Status 

• Administrative 

• Text Search 

• Custom Search Items 

 

NOTE: Hover your mouse over a Search field for details on values allowed (e.g., some 

search fields will allow comma separated, partial, or range values). 

3. Click Search to search for the pathology reports specific to the criteria you have typed.  

Alternatively, you can hit Enter once you are finished entering your search criteria. 

• Search results will be displayed in the Search Window. 

  

eMaRC Search results. 



  

User Guide: 

eMaRC Plus v9.0 

Page 26 of 57 
 

NOTE: To sort reports by a specific column, click the column label. 

4. To open reports, select the checkbox to the left of the report and click Open. If you would like 

to view all reports from the Search results, click Select All and then click Open. 

• A temporary batch will open containing the selected search results. 

• To start a new search, click Clear All Search Parameters to clear all search criteria.  

 

Saved Queries 

If a user searches for the same information on multiple occasions, a query can be saved to reuse at 

another time. 

 

Save Query 

1. Enter the information into any of the 7 tabs. 

2. Click the Save Query… button. 

• The HL7Reader dialog box opens to enter name of saved query. 

  

Saved query name dialog box. 

3. Enter the name of the query and click Ok. 

 

Open Saved Query 

1. To open a saved query, click the Open Saved Query… button. 

• The Saved Queries dialog box opens. 

  

Saved Queries dialog box.  

2. Select the desired query from the list and click Open. 

3. In the search window, click Search to execute the query. 
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Delete a Saved Query 

1. To delete a saved query, click the Open Saved Query… button. 

• The Saved Queries dialog box opens. 

2. Select the desired query from the list and click Open. 

3. Click the Delete Selected button to remove the query from the list. 

 

Search - AND/OR Searches 

Grey boxes appear in some search tabs, grouping data items together. 

e.g. Report Status tab: 

  

Report Status search tab. 

• Processing Statuses are grouped together under the label “Select all status to search/type”. 

• Report Types are grouped together under the label “Report Type”. 

• Exported and Linked reports are grouped together separately from Processing Status and 

Report Type. 

 

OR Search 

When search fields appear within the same grouping box, the search will be an OR search. 

e.g., In the Report Status/Type tab, the following search will provide results of reports that have a 

Processing Status of “Review” or a Processing Status of “Complete”. 

  

e.g. OR search. 
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AND Search 

When search fields appear in different grouping boxes, the search will be an AND search. 

 

e.g., In the Report Status/Type tab, the following search will provide results of reports that have both a 

Processing Status of “Review” and a Report Type of “Hematopoietic”. 

  

e.g. AND search. 

 

 

Export Search Results 

Results from the Search Window can be exported into an Excel file. The User also has the option to 

Export the file out of eMaRC. 

 

Export to Excel / CSV 

1. Open the Search Window and perform desired search. 

• Search results are populated in the Search Results Window. 

 

2. Click the Export to Excel / Export to CSV button at the bottom of the Search Results window. 

    

Export to Excel / Export to CSV button in Search results.  
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3. Choose location and name for file and click Save. 

• Message appears: “Result has been exported to: [FILE LOCATION]” 

 

4. Navigate to save location and open. 

         

Export Abstract Data 

1. Open the Search Window and perform desired search. 

• Search results are populated in the Search Results Window. 

2. Click the Export Abstract Data… button at the bottom of the Search Results window. 

  

Export Abstract Data button in Search Results  

 

3. Export Abstract dialog box will open, select and click export 

  

 

 

Search – Local Search Items 

An Administrator can adjust the search fields in the Custom Search Items tab of the Search window. 

1. Click Administration>Manage Local Search Fields 

• The Select Search Fields dialog box opens. 
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Local Search Items for selection. 

• Columns in the right-hand column (Selected search fields column) will appear in the Custom 

Search Items search tab.  

2. Use the Add and Remove buttons to move data items to the Selected search fields column. 

3. Use the up and down arrows to change the order of the data items in the Selected search fields 

column. 

4. Select a data item in the Selected search fields column and click Relabel… to change the name of 

the data item displayed in the Search window. 
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View Pathology Report 

Workbench 

The view that displays the Pathology Reports in eMaRC Plus is referred to as the Workbench.  

 

eMaRC Plus Workbench. 

When a pathology report is opened, there are two panes displayed by default. The left portion of the 

Workbench Report Display is the Pathology Report and the right side of the dialog box is the Abstract to 

be submitted to the registry. A third pane, the Filter/Search/Report List pane is hidden by default. 

 

Pathology Report Pane 

Functionalities in the Pathology Report are available in the following Tool Bar: 

 

Pathology Report Tool Bar. 

 

Navigate through Pathology Reports 

The back and next buttons allow a user to navigate through the open batch of Pathology Reports. 

 

 

Back and Next buttons. 
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Change Reportability Status of Pathology Reports 

eMaRC uses search terms to determine automatically the reportability of a report. A user can override 

the reportability decision made by eMaRC filters by using the Change Report Status button. 

 

 

Change Report Status button. 

To change the status of a report from Review to Non-reportable: 

1. Open the report you would like to change and click the Change Report Status button. 

• The Change Report Status Pathology Report dialog box will open. 

 

Change Report Status dialog box. 

2. From the dropdown menu, if desired, select a reason why the report status has changed. If an 

appropriate reason is not listed in the dropdown menu, enter the reason in the “Enter other 

reason if not listed above” text box and ensure the “Add this reason to the list above for later 

use” checkbox is selected. The system does not require that a reason be entered to change the 

status of a pathology report.  

 

3. Ensure radio button is selected and click Ok. 

• Processing status displayed at the top of the report will update to selected item. 

NOTE: The Change Report Status button can also be used to change a report’s status 

from a Non-Reportable to a positive cancer report (select “Change status to review” 

radio button).  

 

Hold   

If you require a second opinion on a report, the Hold button can be used to assign a report for review 

for another eMaRC user. 
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 Hold button.  

1. Open the report you would like to hold, and then click the Hold button. 

• The Hold Report dialog box will open.   

 

2. Select the desired user from the list and click Ok. 

• The report is now held for the assigned user and the Processing Status of the report is 

updated. 

 

 

Updated Processing Status. 

 

TEST Report Button 

The Test Report flag can be used to identify the reports of special studies sent by a hospital. Reports 

flagged as Test can be searched from the Report Status/Type tab of the search window. 

 

 

Test Report flag button. 

 

Assign Test Flag 

1. When the report is open in the Workbench, click the Test Report button in the report tool bar. 

• The Processing Status will update as follows: 

 

 

Test report Processing Status. 

 

Remove Test Flag 

2. Open the Test Report you want to unflag and click the Test Report button in the report menu 

bar. 

• The following dialog box will open. 
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Remove Test flag dialog box. 

3. Click Yes to remove the Test flag.  

 

HEME Flag Button 

eMaRC will automatically assign a Heme flag to reports containing applicable keywords for 

hematopoietic reports. A user can also manually add or remove the Heme flag to a report. 

 

 Heme Report flag button. 

 

Manually Assign Heme Flag 

If the Heme flag is not automatically assigned to a hematopoietic report, you can manually assign a 

Heme flag.  

1. When the report is open in the Workbench, click the Heme Report  button in the report tool 

bar. 

• The Processing Status will update as follows: 

 

 

Heme report Processing Status. 

 

Remove Heme Flag 

If the Heme flag is assigned to a report that is not a hematopoietic report, you can manually remove the 

Heme flag.  

1. Open the Heme report you want to unflag and click the Heme Report button in the report menu 

bar. 

• The following dialog box will open. 
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Remove Heme flag dialog box. 

2. Click Yes to remove the Heme flag. 

 

Follow Back Button    

To skip over to the next pathology report, click the follow back button. If this function is used, the 

Processing Status will be changed to read “Follow back” marked in red. 

 

 

Follow-back button. 

 

Print Report Button 

To print the report currently being displayed in the Workbench, click the Print Report button. 

 PICTURE GOES HERE 

 

Print Report button. 

 

Duplicate/Consult Button    

The Duplicate/Consult button is a dropdown menu that will provide the user with a list of links to 

Pathology Reports related to the current open report. This includes: 

• Addendum/amendment reports 

• Consult reports from a secondary hospital 

• Test reports 

• Duplicate reports 

 

Duplicate/Consult dropdown button. 
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Duplicate/Consult Dropdown 

The Duplicate/Consult dropdown menu provides information about the related batch of reports. The list 

of reports is ordered by Message ID. 

  

Duplicate/Consult dropdown list. 

• Message ID: The 1st column indicates the Message ID assigned by eMaRC. 

o Starred Reports: Indicate the report is flagged as the original report. 

o Check-marked Reports: Indicate the current report open in the Workbench. 

• Current Diagnosis Accession Number: The 2nd column indicates the Accession Number 

(Specimen Number) assigned by the diagnosing facility. 

• Duplicate Flag upon Import: The 3rd column indicates the Duplicate Flag assigned by eMaRC. 

• Duplicate Flag by User: The 4th column indicates the Duplicate Flag assigned by a user (please 

see Assigning a Duplicate Flag section for more details). 

• Processing Status: The 5th column indicates the processing status assigned to the report by 

eMaRC (can be manually changed through the Non-Reportable button). 

• ICD-O-3 Coding Values: If the report has been coded, the Site, Histology and Behavior ICD-O-3 

codes will be visible in the 6th and 7th columns. 

 

Duplicate/Consult Window 

Clicking on any of the reports in the Duplicate/Consult dropdown menu will open a new window. This 

window contains a batch of all the related reports so you can browse between them easily.  

The Duplicate/Consult window contains many of the same functionalities as the Pathology Workbench 

window. Please see Pathology Report Pane section for details on functionality. 

 

Assigning a Duplicate Flag 

Users can assign a flag to each linked report to indicate the relationship between the reports.  

 

Duplicate Flag options in Linked Report window. 

To set the duplicate flag, select the flag you wish to set and click Save Flag and Close. 
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NOTE: Clicking Save Flag and Close will close the Duplicate/Consult Window. If there are 

other changes that need to be made to the report (e.g. updating abstract), please make 

these changes before updating the Duplicate Flag. 

 

Errors Button 

If there is an error in a report, an Error icon will appear at the top right of the report body panel. An 

Administrator can set the validation rules to identify errors on import (see eMaRC Plus Administrator 

Guide for more details). 

 

 

Pathology Report Errors button. 

Clicking the Errors button will open a dialog box listing any errors that are caused by invalid or missing 

mandatory segments in the HL-7 message. 

  

Error dialog box. 

Errors can be filtered by type by selecting one of the following options from the Message Filter 

dropdown menu: 

• Data item validation 

• Missing required data items 

• Length validation 

• Segment/message errors 

Raw Data Button 

To view the raw HL-7 message sent by the hospital: 

1. Click the Raw Data button located in the main eMaRC toolbar.  
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Raw Data button. 

• The HL7 message will be opened in a new window. 

NOTE: To search for a term within the raw HL-7 message, click the Find… button and 

enter the desired search. 

  

 

Unprocessed HL7 message. 

 

Highlighted Terms 

eMaRC Plus automatically scans and highlights certain words and phrases for enhanced readability. This 

allows you to recognize easily important text. These words and phrases are identified by color in the text 

of the pathology report pane.  The legend is collapsed by default. 

  

Collapsed Report Legend. 

1. Click [+] Show Report Legend to show the legend. 

  

Displayed Report Legend. 

2. Click [-] Hide Report Legend to collapse the legend again. 
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Abstract Pane 

The Abstract contains information regarding the Pathology Report that will be sent to the Cancer 

Registry.  Information about the patient and facility will be extracted from the HL7 message and 

populated into the Abstract. However, any of the information in the abstract can be manually 

overwritten by a Registrar. 

 

To code a report: 

• Fill in all required fields in the Data to be Coded section of the Abstract Pane. 

• Use the look-up feature to find a code for fields with the Search button  to the right of the 

coding field. 

• Use the drop-down lists to select values for the fields with the drop-down button 

. 

• Complete the abstract by clicking the Save button  . 

• Use the Add Abstract button  to add multiple abstracts to the report (for a report 

with multiple primary tumors). 

• Patient and facility information will be automatically populated into secondary Abstracts from 

the HL7 message. 

• Use the Delete Abstract button  to remove multiple abstracts of the report. 

• Add a Note   to the abstract to make a comment about the report. 

 

Coding Suggestions 

If there are multiple disease site terms within the report, for instance if both Oropharynx and Tonsil are 

present, you can place your cursor on the bottom left corner or the primary site field and eMaRC Plus 

will suggest sites for you to choose as shown below. Select one of the suggested sites from the list, to 

populate the code into the coding field. 

  

Suggested sites 
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Schema ID & SSDI 

Site-Specific Data Items (SSDIs) have been added to the display for cases diagnosed 2018 or newer. 

When a diagnosed case of 2018 or newer is imported and field values are relevant it will auto-populate 

with the correct Schema Id and applicable SSDIs.  

 

Example of Prostate Case with values to produce a valid Schema Id & Applicable SSDIs  

  

Schema ID 

 

Applicable SSDI’s  

 

  

NOTE: When the user makes a change to the Date, Primary Site or Histology they will also need to select 

to have the Schema Id re-pulled for the applicable SSDIs to clear and reset.  
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Abstract Field Properties 

eMaRC Plus allows the user to configure the Abstract view in order to customize the display. These 

properties will be displayed for all eMaRC users. 

1. Click Administration>Manage Abstract Display… 

• The Select Abstract Fields for View dialog box appears. 

  

Select Abstract Fields for View dialog box. 

2. In the Selected fields for abstract display column, highlight the field you want to make changes 

to and click Properties. 

• The Field Properties dialog box appears. 

  

Field Properties dialog box. 

3. Adjust the properties as required: 

• Fore Color: Adjusts the font color of the field. 

• Back Color: Adjusts the background color of the field. 

• Default Value: Sets a default value to the field (which can be changed in the abstract, if 

necessary). 

• Required: When this checkbox is selected, the field is considered a “Critical Field”. The 

report will not be marked as Complete while this field is blank.  



  

User Guide: 

eMaRC Plus v9.0 

Page 42 of 57 
 

• Protected: When this checkbox is selected, the field is considered “Protected”. The user will 

not be able to enter data or change data into this field. 

• Invisible: When this checkbox is selected, the field is considered “Invisible”. This field will no 

longer be in the abstract view to enter data. This field can only be viewed in “Manage 

Abstract Display”: 

 

Select Abstract Fields for View dialog box selected; protected and invisible. 

 

Filter/Search/Report List 

There is a third portion of the Workbench that is closed by default – the Filter/Search/Report List. This 

pane contains a list of reports within the open batch and provides important options to view the 

different types of reports contained in the batch file.  

To view this list, either: 

1. Click Show/Hide List in the eMaRC Tool Bar. 

 

 

Show/Hide List button. 

  

• Click the small black right arrow (>) in the left border of the pathology report pane. 
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Expansion arrow. 

The Workbench will now show 3 panes: 

 

 

3 panes displayed in Pathology Report Workbench view. 

 

Searching within Batch 

A user can search for a report within the batch by clicking on the Search icon  in the 

Filter/Search/Report List. 

  

Search button in the Filter/Search/Report List. 

Filtering Reports within Batch 

A user can filter reports by report type by clicking on the Filter icon  in the Filter/Search/Report List. 

  

Filter button in the Filter/Search/Report List.  
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Users can select the types of reports they would like to see within the open batch and are able to save 

their preferences using the Reports Filter dialog box. 

  

Reports filter dialog box. 

 

Tooltip 

Another function you can enable is Show Tooltip. 

  

Show Tooltip button in the Filter/Search/Report List. 

Once you have selected the Show Tooltip, you have the ability to move your cursor above any pathology 

report and a box will display all the associated information to the pathology report.  If you do not have 

this functionality turned on, you can alternatively scroll on the horizontal bar at the bottom of the panel 

to view all the associated information to the pathology report. 
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Tooltip display in the Filter/Search/Report List. 

 

Pathology Report Display Style 

Each user has the ability to personalize the display of the Pathology Report to their individual 

preference. 

Workbench Pathology Display Style  

A user can alter the Display Style of the report in the Workbench display window. 

1. Click Administration>Manage HL7 Pathology Report Display… 

• The Build Display Style dialog box will appear. 

  

Build Pathology Display dialog box. 
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2. Click Build Display Style… 

• The Display Style dialog box will appear. 

  

Display Style dialog box. 

 

3. Ensure that Workbench Pathology Display Style tab is highlighted. 

• Adjust the settings to your personal preference. 

Body Style: Controls the background of the report. 
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Body Style display: Wheat background 

 

Segment Style: Controls the Segment labels. 

 

 

Segment Style display: shown in navy blue and white font. 

 

Item Header Style: Controls the Pathology Report Headers. 



  

User Guide: 

eMaRC Plus v9.0 

Page 48 of 57 
 

 

Item Header Style display: shown in bold black text 

 

Item Value Style: Controls the text sections of the Pathology Report. 

 

Item Value Style display: shown in black 

 

Bookmark Reports 

To mark a report for future reference, use the Bookmark option. 

Add a Bookmark 

1. When a report is open in the Pathology Workbench, select Tools>Bookmark>Add a Bookmark 

from the eMaRC Menu Bar. 
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Add a Bookmark option. 

 

• The Bookmark Entry dialog box opens. 

  

Bookmark Entry dialog box. 

2. Enter a name for the bookmark and click OK. 

 

Go To Bookmark 

To go to a previously saved Bookmark: 

1. Select Tools>Bookmark>Go To/Manage Bookmark from the eMaRC Menu Bar. 

• The Go To/Manage Bookmark dialog box opens. 
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Go to/Manage Bookmark dialog box.  

2. Double-click on the name of the report you want to open. 

• The report will open to its location within the imported batch. 

 

Manage Bookmarks 

To update or delete Bookmarks from your list: 

1. Select Tools>Bookmark>Go To/Manage Bookmark from the eMaRC Menu Bar. 

• The Go To/Manage Bookmark dialog box opens. 
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Go To/Manage Bookmark dialog box. 

 

2. Select the report to edit from the Bookmark list or type keywords into the Bookmark Description 

field and click Find. 

3. To update the description, highlight the appropriate bookmark, type new text into the 

Bookmark Description field and click Update. 

4. To delete the description, highlight the appropriate bookmark and click Delete.  
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Extracting Information from eMaRC 

 

Export Abstracts and HL7 Messages 

A user can export Abstracts and Raw HL7 messages from eMaRC to the location on their personal 

computer. 

NOTE: privacy and security policies require that any HL7 files containing PHI be stored on 

a sure drive. 

 

1. Click the Export abstracts button from the Tool Bar or select File>Extract Abstract/HL7 

Reports… from the Menu Bar.  

• The Export Abstracts dialog box opens.  

 

Export Abstracts dialog box. 

2. Select the location for the export file by clicking the Browse… button, select a file location, fill 

out the file name and click the Save button. 

3. Click the Export button to create the file of abstracts to send to the repository.  

4. To export HL7 Messages, ensure Export HL7 messages corresponding to the abstracts selected 

for export or Export HL7 messages only. 
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Reports Button 

eMaRC has the ability to run reports and provide output in a .csv file (comma-separated values), which 

can then be opened in Excel. 

1. Click the Reports button in the eMaRC Menu Bar. 

 

 

Reports button. 

 

• The Reports dialog box appears. 

  

Reports dialog box. 

2. Highlight the report you want to run: 

• Facility Submission Status Report: counts the number of reports sent by each facility in a 

specified date range. 

• Facility Submission Status Report by Month: lists the number of reports sent by each facility 

in a specified date range by calendar month. 

• Facility Submission Status Report by Day: lists the number of reports sent by each facility in 

a specified date range by daily submissions. 

• Facility Submission Status Report by Week: lists the number of reports sent by each facility 

in a specified date range by weekly submissions. 

• Display Type Report: list select items and defaults from the Abstract Display. 

• Facility Submission Report by CLIA: list the number of reports sent by CLIA number. 

Access users only have “Display Type” as the available report to run. 
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Print a Report 

1. Highlight the report you want to run and click the Run Report Data button. 

• The Date Range dialog box opens. 

  

Date range selection. 

2. Choose a date range and click Ok. 

• The Report will open in a Print Preview window.  

3. Click the Print button in the top left corner of the Print Preview window. 

  

Print Button in Reports Print Preview. 

 

Save a Report as a Comma-Separated Value (.csv) File 

1. Highlight the report you want to run and click the Export Report Data button. 

• The Date Range dialog box opens. 

 

2. Choose a date range and click Ok. 

• The Save As… dialog box will appear. 

 

3. Choose location and name for file and click Save. 

 

4. Navigate to save location and open .csv file. 

• List will open in Excel. 
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Reports .csv file. 
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Printing Pathology Reports 

 

Print Pathology Report onto Paper 

There are two ways to print full pathology reports: 

1. To print one report at a time: Open a pathology report and click the Print button in the 

Workbench. 

• Select margin and paper information. 

• Review preview, then click Print. 

 

2. To print a batch of reports: Run a search query for reports you wish to print. Click 

• Select margin and paper information. 

• Review preview, then click Print. 

 

Print Abstract onto Paper 

Open a report and click the Print button in the abstract. 

 

Print a Report to .xps or .pdf File 

To print a report to .pdf or .xps file, you will need to change the default printer on your computer. 

1. Click on your computer Start Menu from your tool bar. 

 

 

Windows Start Menu. 
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2. From the right hand side of the menu, select Devices and Printers or for newer versions of 

windows you may have to go through the control panel or settings. 

 

Devices and Printers option. 

 

3. To print to a .xps file, under Printers and Faxes, right click on the icon for Microsoft XPS 

Document Writer and select Set as default printer. 

  

Set default printer. 

 

• A green checkmark will appear in the bottom left corner of the icon to indicate default 

printer was changed successfully. 

4. Print the Pathology Report or Abstract as described above. 

5. When you are finished, change your default printer back to its original setting. 

6. To print to a .pdf file, follow steps 1-5 above. Under step 3, set Adobe PDF printer as the 

default. 


