STELLAR 4.08.01 Release Notes

Jan 23, 2008
STELLAR 4.08.01 is the latest release of the case management software system. The release notes cover the following areas.

1. Who Should Upgrade to STELLAR 4.xx
2. Future Releases and Support for STELLAR

3. What’s New in STELLAR 4.xx
4. Where to Obtain the Upgrade

Who Should Upgrade to STELLAR 4.08.01
If your CLPPP currently uses STELLAR 4.x x,  you should upgrade to STELLAR 4.08.01. There was a defect in STELLAR 4.xx export Lab to DBF function that kept children with an age at time of test greater than 99 from being exported.  It only affected children who had been imported since the site started using STELLAR 4.xx.  
If your CLPPP uses STELLAR 3.x, you should review the “What’s New in STELLAR 4.xx” and the “Future Releases and Support for STELLAR Section” and make a determination if it is beneficial for your CLPPP to upgrade to STELLAR 4.08.
Future Releases and Support for STELLAR

STELLAR 4.08.01 is the last planned release of STELLAR. There could be future releases for the following reasons:

· A critical defect is found in the STELLAR 4.08.01 release.
· Changes are required to enhance data migration to the future STELLAR replacement.
· LPPB changes the CDC Surveillance extract specifications.

Support for STELLAR will be discontinued by LPPB at some point in the future.  Once CDC LPPB has selected a STELLAR replacement and a deployment schedule is developed, LPPB will announce a date for the end of STELLAR support. 

What’s New in STELLAR 4.x (i.e. Changes from STELLAR 3.x)
STELLAR 4.x includes new fields, functions, options, reports, labels and some defect fixes.

New Fields – Child Table

Below is a list of changed/new fields in the Child table.

	Field
	Description

	Actual/Estimated DOB1
	If actual is checked (the default) there are no changes in current function. If estimated is checked, the DOB field is disabled. This option (estimated) should only be used when you receive a lab report without a DOB and with an age listed. The system will calculate an estimated DOB based on the lead result sample date and age of the child provided. The estimated date of birth is calculated as X months/years back from the sample date. All reports will display an estimated date of birth as follows: MM/DD/YYe.

	Current Age
	The current age of the child is displayed in years and months and total months. This is a calculated field and not stored in the database.

	Medicaid Eligible
	Check if the child is eligible for Medicaid. This is the field that will be counted during the quarterly report. When checked displays the Medicaid id field.

	Medicaid ID
	Holds the child's Medicaid id number.

	SSN
	Hold's the child's social security number.

	Country of Origin
	Defaults to United States. Can select from a list of Countries used in the Lead PAM.

	Entry Date
	Entry date into USA. Field is displayed if United States is not displayed as the country of origin

	Pregnant
	Checkbox is only displayed if sex is female

	Due Date
	Estimated due date if patient is pregnant. Only displays if pregnant is checked.

	Deceased
	Check if the child has died.

	Date of Death
	Enter the date the child died. Only displays if deceased is checked.


[image: image1.png]# Chang:

rd for Brown,

ty born 6/05/03

Child |Case | Blood Tests | Address History |

STELLAR ID; 115 Export Status: This site has edit contral
Date of Birth

Name:  [Brown [Betty o  Actual 5
Last st [ El

& Estimated

sex [ < Emicty: [T 2] curen age

Special Ethniciy: | =] Language: [E =] 2years and 0 months. Total months = 24

Guardian Narie:  [Fouss  [whinay | Race - Select al that apily
Lest

I~ American Indian or Alaskan Native

st
Risk & High C Low I~ Asian

¥ Black or Afican A
[ Medicaid Eligible Medicaid ID: [464345848464 S

I~ Native Hawiian or Other Pacific Islander

@it 2 PH:[(404) 2015555 I~ Whits
SSN. 111724516 I” Unknown [~ o

Country  [Cameroon Entry Date: [ 6/03/2004 3] Last Update: 6/21/05

of orign

Next PbB due on I~ Pregnant
¥ Deceased Date of Death: 772172005 ¥
{Memos | Events | Siblings

Reports | 0K Cancel Help





Figure 1 Child Browse Entry Screen

1By default the ability to select an Estimated Date of Birth is disabled.  A user with Administrative security rights can enable use of Estimated Date of Births by selecting the following from the STELLAR main menu:


Edit>Setup Options>Defaults

Check the “Allow Use of Estimated DOB” box.

Child Browse Window – Changes
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Figure 2 Child Browse Screen
By Medicaid ID Tab: Select this tab to limit the display to Medicaid eligible only children sorted by Medicaid ID number.

Color Coding: 
Orange/Brown = Medicaid eligible child that is not a case.




Teal (red in screenshot) = Medicaid eligible child that is an open case.




Blue = Non-Medicaid child that is a case




Black = Non–Medicaid child that is not a case

Locate Button:  Used to start the search after typing information into the lookup field. Tabbing off the look up fields starts the search also as in the current release.

VCR Buttons: Located in the bottom left corner of the browse window provides another method to browse through the database.

New Fields and Screens for the Lab Table

Below is a list of new/changed fields for entering a lab result.

	Field
	Description

	PbB Result Type
	E = Equal to; L = Less than; G = Greater than. Defaults to E. Allows recording of results reported as < or > than some value.

	PbB Result
	Now allows recording  a result with up to two decimal places, i.e. 10.25

	Age Yrs
	Enter age in whole years. Only displays if Estimated is checked for DOB

	Age Mon
	Enter age in whole months. Only displays if Estimated is checked for DOB


NOTE1: Age Yrs and Age Mon are only displayed if an administrator has allowed the use of Estimated Dates of Birth in Setup (Edit>Setup Options>Defaults) and the Estimated option is checked for Date of Birth on the Child Entry or Data Entry screen.

NOTE2: Age can be entered as age in years and months or total months only. For example a child 3 and 1/2 years old could be entered as 3 years 6 months or as 42 months.
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Figure 3 Add a Blood Test Screen
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Figure 4 Data Entry Screen

New Fields Screens – Address Table

Below is a list of new/changed fields for the address table:
	Field
	Description

	Apartment
	Field size increased from 4 to 7 characters.

	Verified
	Check to indicate that the address is verified as correct.

	GeoCoded
	Check to indicate the address was geocoded.

	Latitude
	Latitude of address

	Longitude
	Longitude of the address
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Figure 5 Address Entry Screen
New Functions – Address Validation

This new functionality does not encompass full address verification. It only performs city, zip code and state validation of the address. It does not validate the street address. The zip validation only validates that the zip code is valid for the city entered. The validation can be done during manual data entry, an interactive database scan or a report of problem addresses can be generated.

Data Entry – Address Validation

The address validation works as follows: 
1.   An address is entered and saved as normal. 
2.   Upon save the state field is verified. A warning pops-up if not the correct state, but can be ignored if applicable. 
3.   Next the city is verified against the valid cities in the state. If not valid, a selection list of valid cities for the state is displayed. The currently entered city can be saved even if not on the list if determined to be correct. 
4.   After a valid city is selected, the zip code is validated against list of correct zip codes for the city. If the zip code entered is not valid, a list of valid zip codes for the city is displayed. Again you can ignore the list and save the current zip code. 
    
Automatic address verification can be turned off during data entry by selecting the following from the main menu: 

      File>Address Checking On/Off 

The screen below is displayed after selecting the above menu item.
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Data imported through ELR are not checked, but can be checked by Fix Address Process.
Fix Address Process – Address Validation

This process allows you to scan your database and find records that have an invalid state, city, zip code, missing county and records that have characters not normally expected. You can elect to scan the database for one or more invalid elements. To start the process, select the following from the STELLAR main menu.



File>Fix Address Records
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Check the items you want to validate and press the Go Button.  The process scans through the database in STELLAR address id order.  You can enter the first and last address ids to check, so you can do partial scans of the database.

When a record is found with an invalid element a screen pops-up which allows you to correct or ignore the invalid element.
Invalid Address Report – Address Validation

This report provides a list of address ids that have records with problems. You may want to run this report prior to the Fix Address Process to see how many records have problems. To run the report, select the following from the main menu: 

      File>Reports>Questionable Data>Addresses with Invalid Data
Invalid Address Report – cont
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Figure 6 Invalid Address Report Selection

See sample report below:
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An "X" indicates that the element was invalid in that record.
New Reports

Three new list and counts blood test reports were added: 

      Counts by County 
      Counts by City 
      Counts by Census Tract 

The three new reports have the same layout and format as the current Counts by Provider and Zip Code reports. 
All reports were modified to display < results if applicable and with 2 decimal places.
All reports were modified to display Estimated Dates of Birth if applicable (MM/DD/YYe), the “e” indicates the birth date is estimated.

Additional checks were added to the address an child duplicate reports and the reports execute faster than in previous releases but still require a long time to run.

Mailing Labels

Mailing labels for providers, laboratories and children can now be generated independently of batch processing.  To generate mailing labels select the following from the STELLAR main menu.



Report>List and Counts>Labels
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Figure 7 Mailing Labels
Other Changes

Blood Test Browse: The blood test browse window now displays results of all test types and less than (< )and greater than (>) values if applicable.
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Figure 8 Blood Test Browse
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Figure 9 Updated Case Window

Allows you select the address that was the source of the poisoning which may or may not be the child's current residence. This information is stored here for quick reference purposes only. 

You can now enter the Non paint poisoning sources on this screen rather than entering them as events. They can still be entered as events.
Also has coded values for closure reasons.  See conversion section for more information.
Other Changes – Cont

Mailing addresses: You can now enter a mailing address for a child. If entered the mailing address will be used for letters and labels instead of the primary address. To enter a mailing address for a child, go to the address history window. Enter or select a new address and enter "M" as the address type. Do not close out the primary address. To stop use of the mailing address, enter a date in the last occupied field.
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Figure 10 Enter a Mailing Address
Electronic Lab Reporting (ELR)

If you are using STELLAR to import ELR from Solar Lab, the good news is that STELLAR 4.xx will import existing Solar Lab files without any changes.  By default if the Solar Lab file contains a social security number it will be imported into the new Child SSN field in the child table. 

If the Solar Lab file contains a Bill_ID and the Medicaid field (in Solar) contains a “Y” the bill_id information is placed in the child Medicaid field and child Medicaid Eligible field in STELLAR is checked.

If the Solar bill_id contains information and the Medicaid field (in Solar) does not contain a “Y”, you must tell STELLAR what to do with the Solar bill_id information.  To select the appropriate option select the following from the STELLAR main menu:


Edit>Setup Options>Blood Test Import Options

Select the Solar Bill_ID Tab.  You can elect to place the Solar bill_id information in one of the following Child fields:


Medicaid Field


First User Defined Field


Other ID Field



Second User Defined Field

 Electronic Lab Reporting (ELR) – cont

STELLAR 4.xx eliminates the “Other ID” tab and selections on the “Blood Test Import Options” screen as they are no longer needed since  STELLAR 4.xx contains dedicated Social Security and Medicaid number fields in the child table.

STELLAR 4.xx can not currently import lead results with decimal places and with results reported as less than or greater than some value, i.e. < 2.   This limitation is not due to STELLAR 4.xx, but due to the limitations of Solar Lab.  Solar Lab will be updated in the near future to handle test results with decimal places and with less than and greater values.  STELLAR 4.xx is capable of importing the new file structure from Solar Lab.

Where to Obtain the STELLAR 4.08.01 Software

You can download the STELLAR 4.08.01 installation program by clicking on the link below:

ftp://ftp.cdc.gov/pub/Software/Stellar/Stellar3/stel408.01.exe
Save the stel408.exe installation program to your desktop or other location where it can be found.

List of STELLAR 4.01 to 4.08.01 Changes
** Jan 23, 2008 **

STELLAR 4.08.01 Released

Fixed - Export Lab table to dbf. There was a defect in the export Lab to DBF function that kept children with an age at time of test greater than 99 from being exported.  It only affected children who had been imported since the site started using STELLAR 4.xx

** Apr 25, 2007 **

STELLAR 4.08 Released

Enhancement - Lab Import Module changes made to reduce the number of held records.  The same address with a different apartment number is no longer held.  Similar children who both have Medicaid numbers or both have Social Security Numbers or no longer held if the children’s Medicaid or Social Security Numbers are different.  The children will still show-up on the Possible Duplicate Child Report.

Enhancement - Provider Table Dbase Export - the provider field as it is stored in STELLAR was added back to the dBase Provider export file.

Fixed - Lab Import Module, during lab import (under some circumstances) it was possible that some children may have been marked as Medicaid eligible without a Medicaid number.  To determine if this was possible in your database check the following setup item. Go to Edit>Setup Options>Blood Test Import Options. Click the Solar Bill_ID tab. If the “Child’s Medicaid Field” IS NOT check then it was not possible for any children to be marked incorrectly.  If the “Child’s Medicaid Field” is checked then it is possible that some children may have been marked as Medicaid eligible incorrectly.  To determine if any children are marked incorrectly go to the child browse and enter the following query.

Child Medicaid Status = Y and Child Medicaid ID = 

Leave the id field blank.

If the query finishes and the screen is blank, you do not have any children marked incorrectly.  If you have a few records marked incorrectly, you can edit the records and uncheck the Medicaid Eligible field and save the record. If you have a lot of records marked incorrectly contact STELLAR (stel@cdc.gov or let1@cdc.gov) support for a utility than can be run to automatically correct the records.

Fixed - Dbase activity extract could not be read.

Fixed - Address activity extract the investigation referred date was mapped to the event referred date and the investigation referred date was empty.

Fixed - Reports, PbB result values > 99.99 did not display on reports

Fixed - problem with the lab batch Detail Report of Current Case Follow-up Tests not allways showing the two correct previous test.

Fixed - Reports the Caseworker file record count was missing from the List and Counts>Records Report

** Feb 13 2007 **

Stellar 4.07 Released

Fixed - Some held records would generate a Lab File not open error (Error 37) during import.

** Jan 9 2007 **

Stellar 4.06 Released

Fixed - Import from other sources did not import all the new STELLAR 4.x fields.

Fixed - Browse address - if an address had more than one investigation, the address displayed multiple times when browsing.  This was a display only error and did not affect the data.

Known defect not fixed – Use of the duplicate address or child checking during batch processing will crash STELLAR.  DO NOT SELECT THIS OPTION under setup. 

** Dec 20 2006 **

Stellar 4.05 Released

Updated the Provider export to dbf function to enhance migration of the provider file into the CDC Lead PAM.

** Dec 6, 2006 **

Stellar 4.04 Released

Enhancement – The blood test tab on the address form was updated to show test results the same as they are displayed on the blood test tab of the child form.

Enhancement – On the lab import child match screen added the imported child’s address to help with matching.

Fixed – The delete/reassign inspector function did not work correctly.

Fixed - PBB results > 100 caused errors on export to dbf.

Fixed - Lab Import - Child Match Screen Medicaid eligible indicator (for imported child) sometimes displayed incorrect data. 

Fixed - Browse addresss..when scrolling up and encounter a record with a closed case...the same record appears repeatedly in the browse window.

Fixed - When the browse address function is used on an address where a known  child case exits, from the address screen view child is selected and the tab "case" is selected, the message states that the child does not have a case.

Fixed – Data Entry Screen DOB type does not default to actual.

Fixed - Report Builder Report “SAMPLE DATE BEFORE DOB” would crash Stellar when run.

Fixed - When using browse query and try to search on special ethnicity the program would crash.

** Mar 27 2006 **

Stellar 4.03.01 Released

Fixed – could not manually enter PbB results > 69.

Fixed - could not print batch notice to guardians letter.

Fixed – Batch reports did not display the decimal portion of PbB results.

Fixed – Batch reports did not display the “<” operator for PbB results when required.

Fixed – During STELLAR 3.x to 4.x data conversion the investigation “Moved” close reason was not mapped.

Fixed – During STELLAR 3.x to 4.x data conversion the OQreport.dat file was not copied to the 4.x data folder.  Would receive an error when trying to run the CDC Legacy Quarterly Report. 

** Mar 7 2006 **

Stellar 4.03 Released

Fixed problem with the Stellar 3.x to 4.x conversion that corrupted the social security number if stored in the child other id field.

The child's guardian first name field was not transferred during the Stellar 3.x to Stellar 4.x conversion. This was fixed.

Added address 2 to the labels output in the Children Blood Test Due Report.

** Feb 20 2006 **

Stellar 4.02 Released

Added Medicaid number and status to held child record screen in the lab import module.

Fixed and issue that was also in Stellar 3.x that caused the orphan record report to stop if there where provider memos.

Fixed a restore from archive issue that was also an issue in STELLAR 3.x

** Feb 13 2006 **

Stellar 4.01 Released

Replaced Stellar 3.5c installation set with Stellar 4.01
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