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Infroduction to the Tutorial

Epi Info™ Health Assessment Tutorial

professionals in conducting outbreak investigations, managing databases for public

health surveillance and other tasks, and general database and statistics applications.

With Epi Info™ a user can rapidly develop a questionnaire or form, customize the
data entry process, and enter and analyze data.

E pi Info™ is a series of programs for Microsoft Windows for use by public health

The Epi Info™ program is divided into five core modules: Make View, Enter Data, Analysis,
Epi Map, and Epi Report. Each module has stand-alone capabilities; however, using them for
one project from start to finish adds functionality and efficiency. The Make View module is
the questionnaire or survey designer. You will start your project in Make View, where you will
create a survey and begin setting up your database. Using Enter Data, you will populate your
database with information specific to your survey. The data entered, along with additional
datasets, will be imported into Analysis for detailed study. Data will be plotted in the Epi Map
module. Finally, you will use Epi Report to create a presentation of the findings. This training
does not cover every component of Epi Info™ and is meant for the beginning and
intermediate level user.

How 1o Use this Tutoriall

This tutorial will introduce you to the basic concepts of Epi Info™. Each lesson builds upon
knowledge gained from the previous lesson. It is recommended that you follow the lessons in
the order presented. Finish all the listed steps and practices before progressing to the next
lesson as many of the lessons build upon data gathered from a previous lesson. Data specific
to the course and the scenario will be provided to you as part of the training package. At
various points in the course, you will be asked to access this data to complete the lessons.
Read the Five Goals listed at the start of each lesson to review the core functions you should
understand by the end of each lesson.

Step One

Read the Overview section for each lesson. Each Overview contains a Getting Started
breakdown of the module and information on ways to navigate. The Overview also provides
information on the commands, dialog boxes, or other special features that are unique to each
module as well as information on navigating the module. Epi Info™ uses standard windows
features for navigation such as drop-down boxes and menu navigation, as well as unique
features such as wild card (*¥) searches. The Overview also provides you with screenshots of
the module and introduces you to the basic concepts used in each lesson.
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Step Two

Complete all the step-by-step instructions to learn the basics. Numbered instructions with
some screenshots are provided for you to learn the core functions of each module.
Numbered lessons and instructions can be followed and applied when using Epi Info™
outside of the classroom.

Step Three

Complete the Practice Lessons and Skills Review Exercises when provided. Practice lessons
build upon skills learned during basic lessons. Practices and reviews are opportunities to try
skills without detailed instruction. Skills Reviews will consist of hands-on activities to further
your understanding or a series of questions meant to reinforce basic knowledge. An
Intermediate Analysis lesson is provided at the end of the course. The Intermediate Analysis
Lesson builds upon the skills from eatlier lessons and includes tasks that are more complex.
Each section in Intermediate Analysis includes real world data examples from sources such as
the United States Census Bureau and the Behavioral Risk Factor Surveillance System
(BRESS).

Epi Info™ Resources

Training documentation, technical information, or other resources are available on the Epi
Info™ website at www.cdc.gov/epiinfo.

For questions or problems, contact the Helpline at epiinfo@cdc.gov or call 404.498.6190.

To speak with colleagues around that world about Epi Info™, visit the WebBoard at
http://epiinfo.forum.cde.gov.



http://www.cdc.gov/epiinfo
mailto:epiinfo@cdc.gov
http://epiinfo.forum.cdc.gov/

File Set-Up

You must have the latest version of Epi Info™ installed on your computer. Check the Epi
Info™ website for updates www.cdc.gov/epiinfo.

Once installed, Epi Info™ creates a folder on the C: drive called Epi_Info. Your tutorial
datasets need to be installed inside this folder.

1.

2.

From the desktop, open My Computer.

Open your Local Disk drive, usually named C.

. Locate the Epi_Info folder and open it.

If the EIHA Tutorial folder does not already exist, select File>New>Folder from the
navigation menu.

= If you have downloaded the EIHA Tutorial folder to a different location, right click
the folder and copy/paste it to the new location inside the Epi_Info folder on your C:
drive.

. Name the folder EIHA Tutorial.

Copy (or download) the tutorial datasets to the EIHA Tutorial folder.



http://www.cdc.gov/epiinfo
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Fle Download List

You need download the following files to work through all the lessons in the tutorial. Files are
available on the Epi Info™ website on the Tutorials page.

Tutorial Guide EIHAVer#.DOC (MS Word version)
EIHAVer#.PDF (Adobe Reader version)
You need one of the following: EIHAVer#t. HTM (HTML Browser version)

Project Files Albany_demogz.MDB

Asthma Survey 2005.MDB
Asthma Final MDB

Asthma Survey 2005 Sample. MDB
HospitalPoints. MDB
SchoolPoints. MDB
SymptomsByAgeSample.mdb

MS Excel Files AshtmaTable. XLS
HTML Files CensusAge. HTM
Frequencies. HTM
Frequencies. XML
Epi Report Files My Epi Report2. EPT
My Epi Report2. EPX
WMonth Report2. EPT
WMonth Report2. EPX
Graphics WMonthPieGraph2.BMP
Map Files Albany County boundary_region. DBF

Albany County boundary_region.PR]
Albany County boundary_region.SHP
Albany County boundary_region.SHX
ALBZCTA_region.DBF
ALBZCTA_region.PR]
ALBZCTA_region.SHP
ALBZCTA_region.SHX
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Infroduction to the Scenano

This tutorial is set up to teach Epi Info™ by following a scenario. The tutorial includes a
survey adapted from one used in New York State; however, the survey data used for the
analyses were created for the tutorial. Anonymous data relating to New York State were taken
from different datasets referenced in Appendix I: Data Sources. The survey and datasets
presented here relate to Community Health Assessments, and specifically Asthma; however,
they can be used to teach the Epi Info™ program to any user, and to illustrate how the
program can be used to gather, analyze, and present data.

Scenatio

The local health department (LHD) director of County X gets a Request for Proposal (RFP)
from the state health department saying there are funds available for an asthma initiative.
There is a good chance of getting the funding as the LHD has already done some work with
asthma. To apply for the funding, the director meets with the health education
coordinator/planner to identify data that is needed to write a strong proposal. The ditector
and the planner determine that there are several types of data that would be useful to present
as part of their proposal.

To support the scenario, data has been collected from a variety of current sources. Provided
datasets include aggregate data, map, shape, census, and primary data. In this scenatio
example, you will be using a primary data source (paper survey) to collect information for the
sample population of students from County X. You will use Make View to create the
electronic survey, Enter to add records to your survey, Analysis to import and analyze results,
Epi Map to plot the results, and Epi Report to present your findings. Below is a To-Do list of
the basic steps you will be accomplishing to develop the data needed to apply for funds for
the asthma initiative.




To Do List for Lessons 1-10

Use Make View Create the Electronic Survey

O Create your project MDB- Lesson 1

O Create an electronic version of the survey- Lesson 1

Use the Make View Program Editor to Develop Check Code

O Create Check Code to simplify the data entry process- Lesson 2

Use Enter Data to Add Student Records

O Enter records into your survey and data table- Lesson 3

Use Analysis to Merge Data and Create Statistics

O Open your project MDB in Analysis and view the entered records/data- Lesson 4
O Merge your project MDB with records from an MS Excel file- Lesson 5

O Create Frequencies, Means, and Tables using your data and record the results- Lesson 5
O Create Graphs using your data and record the results- Lesson 6

Use Analysis to Manage and Export Data

O Use the RECODE command to view date information from the survey in a specified
order- Lesson 7

O Export selected data to a new table and create a line graph using the selected records-
Lesson 7

O Use the SUMMARIZE and FREQUENCY commands to create aggregate data sets of
survey information that can be mapped- Lesson 8

Use Epi Map to Develop Maps to Illustrate the Data

O Create a choropleth and case-based map combination in Epi Map to look for
relationships between income and asthma- Lesson 9

O Create Point Maps for the locations of regional hospitals and schools- Lesson 9
O Create a map plotting the count of students with bronchitis per zip code- Lesson 9
Use Epi Report to Develop Report Data

O Use Epi Report to create a report that contains survey data and graphic output from the
first nine lessons- Lesson 10
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Lessonl

Make View: Create a Survey

SUMMARY

This lesson is an introduction to the Make View module of Epi Info™. During this lesson,
you will create your project MDB and create an electronic version of a survey used to collect
data from students in the county.

In order to develop data that can be used to show the need for funds, you must first develop
the survey that will act as your primary data collection instrument. In this example, the survey
has been developed for you and is attached as Appendix B: Parent School Asthma Pre-
Intervention Survey. Lesson 1 guides you through the process of using Make View to create
the survey. At the end of this lesson, you will have experience using the Field Definition
dialog box to make many of the fields needed to collect data from the survey population.

Time to complete: 1.5 hours Beginner
Getting Started with Make View

Overview of basic information to navigate Make View and understand Project creation.
Describes how to use the Field Definition dialog box.

Create Fields, Part 1

Begin using the Field Definition dialog box to create text, date, numeric, and Legal Value
fields. Learn how to set the tab order and name a page inside your Project. Includes a Practice
lesson.

Formatting Options

Learn how to format your workspace by changing grid settings or the background color.
Learn how to format/edit fields in your view by tesizing or aligning fields.

Create Fields, Part 2
Learn how to create a checkbox, group, mitror, and yes/no field. Includes a Practice lesson.
Skills Review

Hands-on series of tasks with fewer instructions and a greater degree of difficulty. Learn how
to create a comment legal field.

BEFORE YOU BEGIN

Install the latest version of Epi Info™ on your computer.
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Complete the File Set-Up section of the tutorial.

WHAT YOU NEED

Appendix A: Code Sheet

Appendix B: Parent School Asthma Pre-Intervention Survey

FIVE GOALS

= Create a project called AsthmaSurvey and a View called PrelnterventionSurvey.
®  Create three pages in a View to hold survey questions.

*  Create a Required StudentID field/variable to track students.

»  Create Date of Birth and Age fields/variables to track student ages.

= Set the Tab Otrder to verify the data entry order the cursor needs to follow.

10



LESSON 1

Getting Started with Make View

Epi Info™ uses the Microsoft Access data format to create Projects, files, or MDBs. Each
Project contains a View and a Data Table. The View contains information about the screen
appearance, or how the survey looks, and how data is entered into the data table. For
example, you will create a View based on the Asthma Pre-Intervention Survey. The View will
be a re-creation of the paper survey along with information about field names, field types, and
Check Code.

The View and the data table live inside your Project or MDB. There can be up to 1,000 views
inside your project. Each view can contain 255 fields. Each field can contain 128 characters.
When you enter data in the Enter module, you will be entering data into your MDB. The data
table contains the actual values associated with your Project or MDB.

The Make View program is used to place prompts and data entry fields on one or many pages
of a View. Since this process also defines the database(s) that are created, MakeView can be
regarded as both the form designer and the database design environment.

Inside each View you will create fields (called variables in Analysis) to hold your data.
Variables can be stored on many pages inside a View. You can use the Program Editor
component of Make View to add Check Code to your variables. Check Code represents a
series of rules applied to your data. One example, used in the tutorial, concerns the calculation
of date fields. You can create Check Code stating that when a date of birth is entered in one
field, the age of an individual is automatically calculated and placed in another field. This
allows you to customize your questionnaire and makes data entry quicker and more accurate.

A Project or MDB
contains all the files that
make up your data table.

TABLE 1 TABLE 2 The Data Tables contain

the fields you create in
Make View and the data

from Enter Data. Tables
VIEW 1 VIEW 2 contain the data used for
Analysls,

1
PAGE PAGE 3 The View Is where you

. will design your survay,
Field 5 [ ] There can be up to

; 1,000 Views inside a
Field6 [ Project. Views hold your
pages and fields.

Pages denote sections
of new information just
as on a paper form.,
Views can hold many
pages.

Fields are placed in
pages and become the
variables used for
Analysis after you Enter
your data.

Database Organization Chart

-11-



EPI INFO™ TUTORIAL

The Make View Workspace

T
e g

1. From your desktop, double click the Epi Info™ icon (3100 IS open the program.

2. Click Make View or select Programs>Make View (Questionnaire) to open the Make
View module. The Make/Edit View window opens.

3. As you read this Overview, use your mouse to view available tasks from the drop-down
menus.

= Menus will not be active until you create a new project in Lesson 1.

This is an example of the Make View workspace. The workspace settings are set to default;
meaning the background color is grey and the grid will be visible when you open a new file.

B sl S| Make Edit view ] =10 x|

File Edit View Insert Format Tools Help

Choose New or Open ta begin

Add Page This is an example of the Make/Edit View
|nzert Page:

TEEERE window. This section is called your View. Once
you create or open a file, you can begin adding
information to your View.

Program

This is the Page
Names panel. Views
can contain many

pages.

You will right click inside the View to bring up
the Field Definition dialog box and begin
working.

From the Page
Names panel, you can
also access the
Program Editor
function of
MakeView and set up
your Check Codes.

The fields created in your view are the same as
those in the paper Asthma Survey. When the
data entered in the fields is imported into
Analysis, you will sort it by field names, also
called Variables.

Navigating Make View

File Menu

Use the File menu to create a new project, open an existing project, save, COpy a view,
navigate to Enter Data, or exit the Make View program.

Edit Menu

Use the Edit menu to cut, copy, paste, move grid, delete a page, rename a page, select
a page, or change the tab order.

12



LESSON 1

View Menu

Use the View menu to navigate to the check commands screen where you can edit
your Check Code.

Insert Menu
Use the Insert menu to insert a new field, a new page, or create a group.
Format Menu

Use the Format menu to set a default font, align fields, change your background
color, or edit your settings. Setting a default font affects all text created by the Field
Definition dialog box after the selection. It will not affect fields created prior to
selection. Settings made to the default font can be altered by the Font for Prompt
button in the Field Definition dialog box.

Tools Menu

Use the Tools menu to import Epi 6 REC files, import Check Code, make a view
from a data table, create a data table, or delete a data table.

Make View Help Menu

The Help menu contains the help file contents, how to files, a command reference,
and the About Make View file.

-13-
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Create a Project

Now you will create the asthma sutrvey/questionnaire. The information entered hetre will
populate your database and be used for analyses in a later lesson. Creating the survey requires
some forethought into the types of analyses you may want to run on your data. For example,
later you may want to see the Means of Age. To do this, you will need to have an age variable
in your survey, and the data must be entered into a Number field type. Think about what you
may want to know later and create your survey accordingly.

You are going to collect primary data to illustrate funding needs for an asthma initiative. To
start, you are going to re-create the Asthma Pre-Intervention Survey in an electronic format.

Refer to Appendix A: Code Sheet and Appendix B: Parent School Asthma Pre-Intervention
Survey as you create the survey.

You need to create a new project and a new view. Once inside the project, you can add pages
and create views to address all the survey questions. Later, you will enter records into the
survey.

Be sure to place all your tutorial files in the EIHA Tutorial folder you created in File Set-Up.

1. From the Make View navigation menu, select File>New. The Create or Open
Project window opens.

2. Using the Look In drop menu, select your C drive.
3. Double click to open the Epi_Info folder.

4. Double click to open the EIHA Tutorial folder you created in the File Set-Up

section.
5. In the File Name field, type AsthmaSurvey.
6. Click Open. The Name the View dialog box opens.
7. Name the View PrelnterventionSurvey.
* View names cannot have spaces or begin with numbers.
8. Click OK

* The name of the window changes to Make/Edit View: PrelnterventionSurvey.
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The Field Definition Box

When you right click inside the View, anywhere inside the gray background area, the Field
Definition dialog box opens. This box is your main interface with the Make View module.
From here, you will create the fields where data will be entered into your survey and assign
names to the variables that make up your data table.

Use the Field Definition dialog box to:
= Enter a Question or Prompt. Use the tab key or your mouse to move from field to field.

=  FEnter a Field Name. Field Names created in Make View are the Variable names used in
Analysis. No two Field Names can be the same.

= Select options for your field. For example, Read Only, creates a field that does not allow
for data entry.

®  Delete an existing field. Right click the text to open the Field Definition dialog box and
click Delete. To delete Legal Values and tables, open the associated table from the Field
Definition dialog box, and click Delete. There is no Undo button or verification prompt,
so be sure of your selection before choosing to delete variables or code tables.
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Field Definition | |

Question or Prompt

;I Font for

Enter the Question or Prompt in this field.

Use the Font for Prompt button to overwrite ;I Prompt
your default font and change the style or size
of text.
Field Names ate the
—Field or Yariable Field Hame names entered in your
L data table. In the
Type I Text j Double click in prompt to chan Analysis module, you
I will use these names
Cize I j to work with your
data.
The Field or Variable Type will set the type of
information entered for your Prompt. id | RelateT TIEw I |
Based on the Type selected, you may be given
I- Repeat the option to select a corresponding Pattern for — Code Tables
the entry. For example, if you select Type as
[T Requirg{ Number, you can select a pattern for that Legal Values

number as #, ##, ###, etc. The Size/Pattern
I- Read O drop-down changes based on the Type of field

selected. Codes

[T Sounde
Field or Variable Types dictate how data will be Comment Legal

I- Retain | entered and how it will be available for analyses
later.

0K Help

Field or Variable Types

From the Field or Variable type drop-down, you can create the following types of variables.
Click Cancel to close the Field Definition dialog box once you are familiar with the available
options.

Text

Creates a text data entry field. Letters or numbers can be entered in text fields. Text fields can
be sized for specific entries, or contain up to 128 characters. Can be used to create name or

address data entry fields.
Label/Title

Creates a title for the page or a label for a question. This field type is not searchable, not listed
in the tab order, and not visible for Check Code. Can be used to create a title in the view.

Text (Uppercase)

Creates a text data entry field that can contain letters or numbers, but forces all text entries to
appear in uppercase only. Can be used to create a data entry field for state abbreviations or
identification fields that must use all caps.
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Multiline

Creates a data entry field that can contain letters or numbers up to two gigabytes of
information. Can be used as a comments field or to enter long addresses.

Number

Creates a number data entry field based on a selected pattern, for example #, or ## H# H##.
Only numbers can be entered in the field. Can be used to enter identification numbers or
ages.

PhoneNumber

Creates a phone number data entry field based on phone number patterns. Select from one of

two patterns, #H#H-HHH#H or HHH-HHH-HHHH.
Date

Creates a date entry field based on a selection of patterns, for example MM-DD-YYYY or
DD-MM-YYYY. Dates entered must match the selected pattern. Can be used to enter today's
date or a date of birth.

Time

Creates a time entry field based on a selection of patterns, for example HH:MM:SS. Times
entered must match the selected pattern.

Date/Time
Creates a data entry field that contains both a Date and Time based on a selected pattern.
Checkbox

Creates a checkbox response. The Checkbox field is treated like a Yes/No field. When using
the Checkbox field, non-selected boxes do not appear as Missing in Analysis. Can be used
with Check All That Apply type questions.

Yes/No

Creates a Yes or No data entry field. Field will accept the typed word Yes or No. Yes/No
fields left blank will appear in Analysis with Missing values for those questions. The yes or no
answer is stored in the database as a 1 or 0. When creating Check Code use the (+) = Yes or
(5 = No to register a yes or no response.

Option

Creates a radio button selection list. Use with Select One Answer Only questions. The Option
field is for mutually exclusive choices; only on choice can be made. If more than one choice is
needed, then use the Checkbox option.
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Command Button

Creates links to other components or files. For example, you can incorporate an executable
button in the view to open Analysis or another program such as Microsoft Excel.

Image

Creates a placeholder to insert images into the view. Use an image field to insert an image per
record, for example, a patient, rash, or bacteria picture. The image file types that are accepted
are Graphics Interchange Format (.GIF), Joint Photographic Expert Group (JPG or .JPEG),
Windows Bitmap Format (BMP), Windows Icon File Format (ICO), Windows Metafile
Format (WMF), and Enhanced Metafile Format (EMF).

Mirror

Creates a field that appears on many pages. Mirror field types only work with multiple pages
in a single view. For example, if a Patient ID is on page one, the value of Patient ID can be
echoed onto another page using the mirror field. Mirror fields are read only.

Grid
Creates a related table/grid that can be inserted into a questionnaire or view to track specific
information, for example, a child’s measurements.

Relate

Creates relationships between your main view ("patent” view) with sub views ("child" views)
ONLY within the same .MDB. For example, link the general patient information to the
patient's record of visits.
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Create Relds Part 1

There are many types of entry fields that can be created in Make View. For this lesson, you
will create fields for Title, Text, Number, Date, and Legal Value.

Create a Label/Title Field

1. To create a field, right click in the Make View workspace. The Field Definition
dialog box opens.

2. In the Question or Prompt field, type the title of your survey.
»  Parent School Asthma Pre-Intervention Survey

= The Question or Prompt box allows you to create a question that holds 128
characters. Entered text always appears centered.

3. From the Field or Vatiable Type drop-down menu, select Label/Title.
4. In the Field Name field, highlight the default field name, and type PreSurvey.

* The Field Name will take part of the Question or Prompt and will
automatically create its own name. Because the Field Name cannot begin
with numbers, if a number is the first character in the Question or Prompt, a
letter will precede the rest of the Field Name.

*= Notice that your Field Name is the same as your title. Field Names are
created automatically by Epi Info™ based on the data entered in the
Question/Prompt field.

* Field Names are also called Variable Names. Variable Names are used by the
Analysis module. Tty to create names that will be easy to reference later in
Analysis.

= Field Names cannot have spaces in them.

= Some applications that work with Epi Info™ cannot use field names longer
than eight characters. Keep this in mind if you will be using your data with

other statistical programs.

= TField Names cannot be changed once your data table is set in the Enter
module.

5. Click Font for Prompt. The Font dialog box opens

* The Font for Prompt button is used to change the font setting for the
question or prompt for the field.

6. Select a font from the list.
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7. Make the font Bold and size 14.
8. Click OK Your title text has been formatted with the new font type

= A Label/Title field cannot be used to create Check Code, cannot be
searched, nor is it included in the tab order list.

9. Click OK The title of your survey appears on the page.
= To move your title to the top center of the page, use the click and drag

technique. Select the text with your mouse, left click and hold while moving
the text to the desired location.
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# Practice

Add instructions to the survey.
Right click in your view to open the Field Definition box.

Create a Label/Title Field that states, "Please answer all the questions below, whether or not
your child has asthma."

Give your variable the Field Name Instruction.
Make the font size for your instructions 12.
Move your instructions underneath the title.

Follow the same process to create Text type fields for the following:

Prompt /Question Variable Field Name Other
Type
School ID Number Text SchoolNum
Student ID Number Text StudentID Select Required option.
Zip Code Text Zip

Notice that you are making fields generally considered numeric into text fields. This is to
ensure that theses numbers will always appear as entered.

To restrict the number of characters that can be entered in a text field and thereby control the
data entry process further, you could select from the size drop-down located in the Field
Definition dialog box, and limit the number of characters allowed during data entry. When
thinking about form design, you would need to consider potential errors that could be made
by allowing typing into all fields. Creating Legal Value drop-down boxes (covered later) are
another way of controlling data entry and limiting potential typing errors.

Page 1 of your View should look similar to this example:

m _|EI|5| it Make/Edit ¥iew: AsthmaSurvey

Fle Edit Yiew Insert Format Tools Help

Add Page
Ingert Page
Delete Page

Proaram :_
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Create a Legal Value Field

When you create a Legal Value or Comment Legal field, you are creating a drop-down menu
within your view. Only selections from the drop-down menu will be accepted during data
entry. When creating a Legal Value field, the variable type must be Text.

The dataset contains a question about gender, which you are going to make a Legal Value
field.

1. Open the Field Definition box.

2. In the Question/Prompt field, type Gender.

3. From the Variable Type drop-down, select Text.
4. Use the default Field Name, Gendet.

5. From inside the Field Definition dialog box, locate the Code Tables section.

—Code Tables

Legal Walues

Codes

Comment Legal

6. Click Legal Values. The Set Up Code/Legal Links dialog box opens.

7. Click Create New. An entry box opens for your selected value.

8. In the first line, type Female and press Enter, then type Mal and press Enter.
9. Click the Do Not Sort checkbox.

* Make View sorts all Legal Values alphabetically, unless you select Do Not
Sort.

10. Click OK to accept the Legal Values.
11. Click OK to accept definition entties.

= Notice your survey now contains a drop-down box with the values, Female and Male
as selections.

22



LESSON 1

Create a Date Field

The Date field is a numeric field with pre-set date patterns that are selected from the pattern
drop-down menu.

1.

To create a date field, right click in the Make View workspace. The Field
Definition dialog box opens.

In the Question/Prompt field, type Child’s Date of Birth.
From the Variable Type drop-down, select Date.
From the Pattern drop-down, select MM/DD/YYYY.
In the Field Name section, type DOB.

Select the Required option.

Click OK

Create a Numeric Field

The Number field is a numeric value field that has six predefined value patterns. A new
pattern can be created by simply typing the pattern into the Pattern field.

Similar to Date Fields, selecting a Field type of Number gives you many Pattern selection
options. You need several types of number fields to complete the survey.

1.

2.

Open the Field Definition dialog box.

In the Question/Prompt field, type Age.

From the Variable Type drop-down, select Number.
From the Pattern drop-down, select ##.

Use the default Field Name, Age.

Select the Read Only option.

. Click OK.

* In Lesson 2, you will create a Check Code to calculate this field, based on the
child's date of birth.
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# Practice

Create the Phone Number and PS School Number fields.

Hint: Phone Number is a new variable type.

Prompt/Question Variable Type | Field Name | Other

Home Phone Number PhoneNumber | Phone Select the Pattern
HHT-RA A

PS School Number Text PSNumber Select Read Only
option.
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Set the Tab Order

The tab order is set automatically based on the positioning of the fields in your View;
however, you can manually change the order of tabs in your survey. If you do not verify the
tab order, then your cursor may jump to fields out of sequence with data entry and cause
etrors.

You want to be sure that the order of fields matches the way information will be entered from
the paper survey. Refer to Appendix B to review the field order of the paper survey.

1. Click Edit>Order of Field Entry (Tab Order). The Otrder of Field Entry
dialog box opens.

Order of FieldEnkry x|

Page Controls:

Tab Index | Prompt MHame Tab Stop

1| School ID Humber SchoolMurm | True

2| Student ID Mumber Studentld True Cancel |
3| Zip Code Zip True

4| Gender Gender True

[=

5 [Child's Date of Birth Up |

Age Age True

5
7[Home Phone Mumber Fhone True
8| PS School Number PSHumber | True Dowin |

2. Select the field order you would like to impose by selecting a prompt and then
using the up and down buttons.

* For example, the variable Age should come after the variable DOB.
3. Click OK to accept the new tab order.

4. C(Click File>Save.
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Name the page

If your survey contains more than one page, use the Page Names window to navigate pages. The
Page View Menu Panel displays the created Views' names and gives you access to created pages.
You can Add Pages, Insert Pages, and Delete Pages from this menu.

The Make View Program Editor can be accessed from this menu panel by clicking the Program
button. If you have a Related View in your project, the Home and Back buttons are available to
navigate between parent and child views.

1. From the Page Names panel, right click on the Page Name 1. The Pagename
window opens.

2. In the Page Name Field, type Personal Information.
3. Click OK The page name appears in the list.

Page 1 of your View should look similar to this example:

1

R R ST F

Add Page
Ingert Page
Delete Page

o e A

ool 1D Number

Program
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Create a Code Table

There are four schools responding to the survey. To ensure accuracy and speed of data entry,
you are going to create a Code Table that links the information entered in the SchoolNum
field to the information in the PSNumber field. This means that each time a School 1D
Number is selected from the drop-down, the field PS School Number will be automatically
populated based on the data table values you create. This helps to ensure consistency and
eliminate errors during data entry.

1.

Right click on the text School ID Number to open the Field Definition dialog
box.

*  PSNumber and SchoolNum must be Text type fields.
®  PSNumber must be set to Read Only.

From the Code Tables section, select Codes. The Set Up Codes/Legal Links
dialog box opens.

Select PSNumber as the field you want to link to SchoolNum.
Click Create New. The Codes for Field box opens.

= The schools are named A, B, C, and D. Based on the School ID Number selected,
you want the corresponding PS School Number to populate automatically.

On the first line enter 4. Tab over and type 723 as the PSNumber.

{r. Set Up Code,/Legal Links ) x|

Codes for field: SchoolHum

SchoolMum P=Mumber v D':'n':'tS':'f'E

A 123

B 234 OK

C 345
A 436 Create Hew
*

Uze Existing Table

Cancel
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6. Use the tab key to navigate through the table set-up. Complete the series as
follows:

= SchoolNum B and PSNumber 234
= SchoolNum C and PSNumber 345
= SchoolNum D and PSNumber 456
7. Select Do Not Sort.
8. Click OKin the Legal Links dialog box.
9. Click OKin the Field Definition dialog box.
= School ID Number # now contains a drop-down menu. Once you select a School

ID Number, the PS School Number will automatically populate with the value you
entered in the code table.
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Formatiing Opfions

This section outlines ways to customize your workspace and to edit fields in your View. Try
changing the background color or altering the grid settings. Color changes will appear in the
Enter module.

Changing the Background Color

You can alter the background color of your Make View workspace and apply the changes to
one or all pages in your project.

= Select Format>Background. The Background dialog box opens.
* (lick Change Color. The Color selection window opens.

= Select a new background color for your survey.

* Click OK to accept the selected color.

= Select Apply to Current Page Only or Apply to All Pages.

* (lick OK to view your selection.

* (lick Clear Color from the Background dialog box return to the default grey.
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Changing the Grid Settings

Grid settings give you a way to align the fields in the View. There are several ways to
customize your grid settings.

From the Make View navigation bar, click Format>Settings. The Snap to Grid dialog box
opens.

ir> Snap to grid _ x|

Snap to grid Wizible grid on screen

v Snap to gnd on [+ “izible grid on

I3 ﬂ Character widths between gnd lines

{~ Snap left side of prompt bo grid

{* Snap left side of entry field to grid

] Cancel

The default setting of Snap to Grid is On. When moving a field on the View screen, the field
will snap to the left portion of the grid it is closest to. You have the option to snap based on
the prompt or the entry field. Select the Snap to Grid option if you want your fields to snap
in line with your grid when they are created or moved. De-selecting the Snap to Grid
checkbox allows you to move fields to any location on the page.

Select the Visible Grid option if you want your working space to contain a grid while
designing the View. The grid is not visible in the Enter module. Visible Grid on Screen,
allows you to remove the visible grid from the MakeView screen. If the checkmark is on, then
you have the option to change the width between the grid lines.

You can change the size of the grid spacing by using the up and down arrow keys next to
Character Widths Between Grid Lines. Changing the widths of the grid lines, gives you
more control over the spacing of fields.
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Resizing Fields

Entry fields can be resized.

Left click an entry field box (not the prompt text).

Use the blue bounding box and the click and drag method to make the data entry boxes
larger or smaller.

The numbers inside the fields tell you how many characters are visible in the survey.

To resize a drop-down box, press the Alt key and left click to get the blue bounding box
and resize using the blue bounding box handles.

Aligning Fields

Fields can be selected and aligned either horizontally or vertically.

Left click at the corner the field you want to align.

Hold your mouse button and drag a rectangle around several fields.

Select Format>Alignment>Vertical or Format>Alignment>Horizontal. The
selected fields will line up based on your selection.

PSSchool# [ ZipCode [0
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Copying and Pasting Fields

Fields can be cut, copied, and pasted.

Left click and drag a rectangle around the field you want to copy.
Select Edit>Copy.

Select Edit>Paste. The pasted field appears on top of the copied field.
Left click and drag the field to move it.

Right click the pasted field to open the Field Definition dialog box. Notice that a number
has been added to the Field Name since field names must be unique.
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Create Felds Part 2

Now you will create the asthma history section of the survey. The first question on the paper
survey is a seties of yes or no checkboxes related to asthmatic conditions. You are going to
create one checkbox per condition and then group all the conditions. This will allow you to
analyze how many students checked Yes per condition and to analyze the conditions as a
group. A single checkbox will indicate a yes if checked and a no if blank. To create the next
section of the survey, you will need to create separate fields for the question and the
checkboxes.

Questions have been shortened in the electronic survey; refer to Appendix B Parent School
Asthma Pre-Intervention Survey to see the original questions.

You are not going to create the entire survey in Lesson 1; however, you can use the field
information in the Appendix A: Code Sheet for additional practice.

Add a New Page
1. From the Page Names panel, click Add Page. The new page appears.

2. Right click inside your new page. The Field Definition dialog box opens.

3. Enter the following Prompt: Has a health professional ever told you that your child has any
of the following conditions?

= For long questions, you may need to enter a line break inside your prompt.
To do this, hold the Ctrl key and press Enter inside the sentence where you
want the break to occur.
4. Select Label/Title as your Variable Type.
5. Type the Field Name: Condition.

6. Click OK
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Create a Checkbox

1. Under the question, right click to open the Field Definition dialog box.

2. Enter the following Prompt: Asthma.

3. Select a Variable Type of CheckBox.

4. Use the default Field Name, Asthma.

5. Click OK. The Asthma checkbox appears in your view.
* In the Enter Data module, checkboxes appear as selected or not selected.
= In the Data Table, checkboxes ate stored as -1 and 0.

*  When used in Analysis Commands, checkbox values are selected and coded
as (+) and (~).

# Practice

Create three checkboxes to complete the question.

Arrange the checkboxes near each other and align them horizontally or vertically, depending
on your workspace and preference.

Prompt/Question Variable Type | Field Name | Other
Reactive Airway Disease Checkbox RAD

Asthmatic Bronchitis or Checkbox Bronchitis

Wheezy Bronchitis

Wheezing Checkbox Wheezing

Your checkboxes should look similar to this example:
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Create a Group

Groups can be created to organize similar data on a survey. Variables that are part of a group
can be analyzed alone or as part of the group. Take the question and the variables regarding
conditions and group them.

1. Use the left mouse button to drag a rectangle around the fields that are to be
included in the group. This includes the question and the four variables.

—e—ba—ds

I L
e followmg ;con 1|t|qns7

mchl is |

2. TFrom the navigation menu select Insert>Group. The Group Dialog box opens.
3. In the Group Description field, type Asthmatic Conditions.

» To select a different color for the group, click Set Color.

Group Description

| ssthmatic Conditions]

Set Calor k.

Cancel

4. C(lick the OK
= To Edit or Ungroup, right click inside the group name. The Edit Group dialog opens.

* To Resize the box containing the group, double click inside the box. A resize arrow
appears.

= To move the entire group, left click the group title text, hold, and drag to the new
location.

e followmg ;con d |tiq'lns?i
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Create a Mirror Field

Mirror fields allow you to show one field on many pages, but only enter the information once.
Because there are several pages of information for each child, you want to place their Student
ID on each page.

1. Open the Field Definition dialog box.

2. Enter the Prompt as ID.

3. Select the Variable Type: Mirror.

4. Use the default Field Name, ID.

5. Click OK. The Assign Variable to Mirror Field dialog box opens.

6. Sclect the variable StudentID from the list.

7. Click OK

8. Move the field to the top of the page.

* In the Enter Data module, once the Student ID # field is entered, it will
populate this field automatically.
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Create a Yes/No Field

1.

2.

Open the Field Definition dialog box.

Enter the following Prompt: Has a health professional prescribed any medication to your
child for breathing problems?

* The original question has been modified as it contained more than 128
characters, which is more than allowed in the prompt field.

Select the Vatiable Type: Yes/No.
Type the Field Name: Medication.
Click OK.

*  From the Enter Data module, only the text Yes or No can be entered in this
field.

* In the Data Table Yes/No values ate stored as 1 or 0. Missing values appear
blank.

*  When used in Analysis Commands, Yes/No values are selected and coded as
(+) and (-). Missing values are selected and coded as (.).
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# Practice

Create a new type of drop-down selection box called Comment Legal.

=  Comment Legal fields are set up like Legal Value fields, except that Comment Legal fields
allow you to place a number in front of text, so that, when populating fields, a number is
entered. This is a text field, but it will display as a number in the Analysis module.

Create a group that contains the variable Symptoms, Whistle, and Cough. Name the group
Monthly Breathing Difficulties.

Name Page 2 _Asthma Symptoms.

Prompt/Question Variable Type | Field Name | Other

Select the month when your Text WMonth Click Comment
child's breathing was the Legal. Create a New
WOTtSt. Table.

Enter each month of
the year in the
following format:
1-January 2!
February 3- March,
4- April, 5- May, 6-
June, 7- July, 8-
August, 9-
September, 10
October, 11-
November, 12-
December

Select Do Not Sort.

During their worst breathing | Label/Title Symptoms
month, select how often the
following symptoms
occurred.

Wheeze or whistling in the Text Whistle Legal Value
chest?
The 5 Values are:
Never

2 times each week or
less

3 to 6 times each
week

Every day, but not all
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day
Every day and all day

Select the Do No
Sort Checkbox.

Have a cough?

Text

Cough

Legal value

You can use an
existing Legal Value
table to populate new
tables. From the Field
Definition dialog box,
click Legal Values.

From the Set Up
Code/Legal Links
dialog box, click Use
Existing Table. The
Select a View dialog
box opens.

Select codeWhistle.
Click OK. The Select
a Field to Link dialog
box opens.

Select Whistle. Click
OK The Legal
Values for Cough
populate.

Select the Do Not
Sort checkbox. Click
OK
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Page 2 of your View should look similar to this example:

P [l B3 Make/Edit Yiew:PreInterventionSurvey
1 Personal Information
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Skills Review
Add a Page to the View.

Create a numeric variable to hold the number of missed school days.

The survey asks respondents if they have missed sports activities. The variable MissSport is a
Yes/No variable. Create a Legal Value variable that asks for mote information if the
respondent answers Yes. Align the question to the MissSport variable.

Create a numeric vatiable to hold the number of people living in the home with asthma.

Verify the tab order for all your pages. You want your cursor to follow a logical data entry
path.

Name Page Three Medical Information.

Select File>Save. Epi Info™ saves your data automatically, but it is a good idea to save after
you add new information.

Prompt/Question Variable Type | Field Name | Other

How many days of school has | Number MissDays Pattern ###
your child missed due to
breathing problems?

Have breathing problems Yes/No MissSport
stopped your child from
participating in sports?

If Yes, how many times in the | Text SPTimes Legal Value
past month.
2 times a month or
fewer

3 to 4 times a month

1 to 3 times each week
4 times each week or
more

Select Do Not Sort

How many people living in Number IHome Hit
your home, including this
child, have asthma?
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Page 3 of your View should look similar to this example:

Make,/Edit ¥Yiew:PreInterventionSurvey
Personal Information | File  Edit Wiew Insert Format Tools Help
2 Asthma Symptoms
Medical Information
o
of school has your child: d
Add Page
Ingert Page
Delete Page
Program
How many people

If you need to close Epi Info™ before completing your survey, the New Data
Table dialog box will appear and prompt you to create a Data Table. Click Cancel.
You do not want to create a data table until you are ready to enter data.

®  When you exit either by going to File>Exit or clicking the close X, the New
Data Table dialog box opens.

= (lick Cancel.

= If your data table is set before you are ready to enter data, you can use
Tools>Delete Data Table to reset your View. This will allow you to make
edits to your field names and add code tables.

WARNING: This function should only be used if you have not entered any
data; otherwise, all your data will be deleted!
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Lesson Complete!

WHAT YOU LEARNED

LESSON 1

How to
* Navigate Make View.

= Create a new project.

= Use the Field Definition dialog box to create fields.

* Add pages to a View.

= Customize a View.
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Lesson2

Make View: Chedk Code

SUMMARY

This lesson is an introduction to creating Check Code inside the Make View module of Epi
Info™., In this lesson, you will learn how to customize your survey by creating a series of data
entry rules. You will also learn the components of the Make View Program Editor.

In Lesson 1, you created a variety of fields to collect data for your survey. In Lesson 2, you
will use the survey you created and add Check Code to some of the fields. Check Code makes
the data entry process faster and more efficient, so there are fewer errors when you begin
using the data later to create the statistics and develop your report.

Time to complete: 2 hours Intermediate

Getting Started with Check Code

Overview of basic information to navigate the Program Editor and understand Check Code.
A list of available commands is provided. Functions and Operators are defined.

Create a Skip Pattern

Use the Program Editor to create an IF/THEN statement. Also introduces the commands
ELSE and GOTO.

Use the ASSIGN Command

Use the Program Editor to create a mathematical function that calculates the Age field based
on entries in the Date of Birth field. Use the YEARS function.

Use the DIALOG Command

Use the Program Editor to notify data entry personnel of specific data entry rules or errors to
avoid.

Skills Review

Series of five review questions based on the reading and hands-on activities in this lesson.

BEFORE YOU BEGIN

Complete Lesson 1 Make View: Create a Survey
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WHAT YOU NEED

Appendix A: Code Sheet
Appendix B: Parent School Asthma Pre-Intervention Survey
Asthma Survey.MDB- created in Lesson 1

Appendix D: Skills Reviews Answer Key

FIVE GOALS

® Be able to open and navigate the three sections of the Make View Program Editor: the
Command Tree, the Check Commands window, and the Program Editor code window.

= Create a skip pattern using an If/Then statement.
®  Create code using the ASSIGN command.
®  Create code to calculate age using the YEARS function.

*  Create a DIALOG box that appears during data entry and prompts the user to verify
their data.
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Getting Started with Check Code

Check Code is used to validate data entry and to make the process of entering data faster.
With some advance planning, you can create code that will do calculations, skip questions
based on answers, prompt the user with dialog boxes, and populate fields across pages and
records. In its most basic form, Check Code is a set of rules for the person entering data to
follow. Check Code helps to eliminate errors that can occur when entering large amounts of
data.

Open the Program Editor by selecting the blue Program button located in the Page Names
window or by selecting View>Check Code from the Make View navigation menu.

The Make/Edit View: Check Commands window contains three working areas: the Check
Command Tree, the Make/Edit View: Check Commands window, and the Program Editor.
The Check Command Tree is not visible until you select a variable from the drop-down
menu.
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The Program Editor Workspace

To access the Program Editor and create Check Code, you must open the survey you created

in Make View Lesson 1.

1. Open the Program Editor by clicking the blue Program button from the Page Names
window or selecting View>Check Code. The Make/Edit View Check Commands

window opens.

selected.

Notice that the Page Names window is still open since a variable has not been

This is an example of the Program Editor/Check Code wotkspace. The top of the page

shows you ate in the Make/Edit View: Check Commands window.

B IISTEA] |7 Make Edit View: Check Commands

x|
el Choose field where action will occur
2 Medical Information Before ar Ater
3 Asthma Symptoms
e | | [ " Befare & After OK | Cancel |
4dd Page This is an example of the Make Edit/View: Check
Ingert Page ~ommands window.
s C d d
Delete Page
Proaram
:
Edit Wiew Fonts Help
w | open | swe | pam | mm Run This Command
The Page

Names window
is still visible
since a variable
has not been

selected.
This is the Program Editor window.
Code can be typed directly into the Program Editor in this space. Always Save
your code before leaving the Program Editor.
Editing a View
PrelnterventionSurve| | 4

ol

2. From the Choose Field Where Action Will Occur drop-down, select a variable. The
Make/Edit Check Commands window updates to include the Check Command Tree and

the tab selector.
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it Yiew: Check Commands . x|
Choose field where action will occur

Assign Eetore or After
- Hide [ Studentin i | [  Before & Alter 0K | Cancel |
Unhide
Goto
Clear User \ntelaclion‘[ Fields I Recards I Frograms T Variables . .
Notice the tab selection buttons. You can use the

Autosearch

ol tabs and buttons to access the same commands that
Defi A . .

- Execute e | | are listed in the Command Tree.

-.Dialog

- Help

When creating codes that use multiple commands
you may need to use a combination of commands
| from the Tree and the tab selector.

Program Editor - New Program e

Edit VYiew Fonts Help

Hew ‘ oOpen | Save | Print

The Check window
shows the different

commands that can
be used to create
Check Code.

The Check window
will not open until
you select a variable
from the Action Will

Oceur drop-down Variables with Check Code will be tagged with an * in the Choose Field Where
menu. Action Will Occur drop-down.

Once you create Check Code, it appears in the Program Editor.

Check Code must be associated with an existing variable, page, view, or record. The
commands are executed when the data entry cursor enters or leaves the selected
variable. Variables available for Check Code are organized by page in the drop-down

menu.

The Check window and Command Tree display a list of all available check
commands that can be used in the Make View program. Clicking on one of the
Commands opens the wizard or dialog box needed to create the selected kind of
code.

The Make/Edit View: Check Commands window allows you to select when and to
which variable the Check Code program you create will be applied. Previously created
Check Code can be accessed from this window. Use the drop-down list to view the
available variables. Any variable tagged with an asterisk (*) has Check Code associated
with it. Select the variable to view the code inside the Program Editor. Since you have
not created code yet, none of your variables will be tagged.

The Program Editor displays the commands created from the Check Command
Tree. If you have experience with coding, you can type directly into the Program
Editor and save your code without using the wizards or the Command Tree.
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Navigating the Program Editor

Familiarize yourself with the available commands and options present in the Program Editor.

Click Cancel to close any Command Option boxes you open during the Overview.

Click Cancel from the Check Commands window or the close X to exit the Program
Editor prior to starting the next lesson.

Make/Edit View: Check Commands Window

The Choose Field Where Action Will Occur drop-down shows a list of fields in
the current view. Read Only variables will not execute Check Code.

The Before or After radio buttons tell when the action will occur or when your
Check Code will run in the data entry process. You can create code that runs before

you enter data in the selected field or after you enter data when your cursor leaves the
field.

The Tab section gives you another way to navigate and select commands. Click a tab
to open it and see which command buttons are associated with it. Commands
selected from the Tab section open the same wizards/generators and dialog boxes as
the Command Tree.

Check Window

The Command Tree is located inside the Check window. Commands located inside
the Check window act as buttons when clicked. The dialog boxes that open when
you select a command are also called wizards or generators as they are used to guide
you through the Check Code process.

Once you begin creating code, the Command Tree will not be active while inside

some of the dialog boxes. When that occurs you must use the tabs to select
commands.

Available Commands

Define

Use this command to create new variables. Located on the Variables Tab.
Assign

Use this command to assign the result of arithmetic or string expression mathematics
to a variable. Located on the Variables Tab.
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Hide

Use this command to hide a field from view and make it a read only NOENTER)
field. Located on the Fields Tab.

Unhide

Use this command to make a field visible and return it to the status it had before it
was hidden. Located on the Fields Tab.

GoTo

Use this command alone or in an IF statement to transfer the cursor to a specifically
named variable field. Located on the Fields Tab.

Clear

Use this command to set the field named to the missing value, as though the field had
been left blank. CLEAR is frequently followed by the GOTO command that puts the
cursor in position for further entry after an error. Located on the Fields Tab.

Autosearch

Use this command to cause Enter to search for one or more matching records. If a
match is found, you can display and edit the matching record(s) or ignore the match
and continue to enter the current record. Located on the Records Tab.

If

Use this command to define conditions and/or consequences that result when the
conditions are met. An alternative consequence can be given after the ELSE
statement. Located on the Records Tab.

Execute

Use this command to execute a Windows or DOS program. Located on the
Programs Tab.

Dialog

Use this command to provide interaction with users from within a program. Dialogs
can display information, ask for and receive input, and offer lists for making choices.
Located on the User Interaction Tab.

Help

Use this command to display an .HTM or .CHM document. Located on the User
Interaction Tab.
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Program Editor Menu
Edit

Use the Edit Menu to copy, cut, and paste code. You can also edit your code with
Delete Line and Replace Line options. Search your code using Find, Find Next,
Program Beginning and Program End options.

View

Use the View Menu to see additional menu options. Use the Status Bar to see
information displayed about your script. Use the Tool Bar to edit your script.

Fonts

Use the Fonts Menu to change the font type, style, size, and color that appears in the
Program Editor.

Help
Use the Help menu to view the help file contents.
Save

Use the Save button to save the Check Code you created in the Program Editor. The
Save button also verifies that the code syntax is correct.

Print

Use the Print button to make a paper copy of your code.
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Functions and Operators

Check Code is created using a seties of functions and operators. Functions
and Operators are used inside commands to perform tasks such as extracting
a year from a date, combining two numeric values, or testing logical
conditions. Check Code can be typed directly into the Program Editor or
created using the dialog box generators. Within each dialog box, there are
Function and Operator buttons to guide you in creating the proper syntax for
your Check Code. You can also click Functions from within each dialog box
to see a list of all the available functions and examples of the proper syntax.

Functions modify the value of one or more variables to produce a result. For
example, the function ROUND produces a whole from a variable that has
decimal places. Almost all functions require arguments enclosed in
parentheses and separated by commas. Where arguments are required, do not
place spaces between the function name and the left parenthesis.

These are the function buttons available using the Program Editor dialog

boxes.

AND OR "Yes" "No™ "Missing™

Operators are used to combine two items. For example, the "+" operator
combines Varl and Var2 to produce a sum, as in Var3=Varl+Var2.

These are the operator buttons available using the Program Editor dialog
boxes.

+ . *= I — { } & n { ]

+ Addition = Equal or Assign

- Subtraction < Less Than

* Multiplication > Greater Than

/ Division <> Less Than or Greater Than (not Equal
to)

& String Concatenation " Enclose dialog or text

(Parenthetical Expression | ) Parenthetical Expression
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Create a Skip Pattern

Skip patterns can speed up the data entry process by moving the cursor to a specified field
based on the answer to a question. In this survey, parents were asked if their children have
missed sports due to breathing problems. If they have missed sports, then you want them to
specify how often, if they have not then you want them to move to the next question.

To create a skip pattern, you will need to use the IF command. First, plan out what you want
the code to accomplish.

If a respondent answers Yes, they have missed sports, Then you want the cursor to GoTo
the next question. Else (if they answer No) you want the cursor to GoTo (or skip) to a new
question.

MissSport Variable

SpTimes Variable
Have breathing problems stopped IF > Yes THEN GOTO—— If Yes, how many times in the past
your child from participating in manth?
sports?
ELSE

GOTO

l

IllHome Variable
How many people living in your
home, including this child, have
asthma?

IF/THEN Diagram: Creating a Skip Pattern
To create a skip pattern inside the survey, you are going to use the Program Editor.

1. Click Program from the Page Names window. The Make/Edit View: Check
Commands window opens.

2. From the Choose Field Where Action Will Occur drop-down, select MissSport.
* You want the action to occur After data is entered into the MissSport field.

3. From the Records tab or the Check Command Ttree, select If. The IF dialog box
opens.

4. From the Available Variables drop-down, select MissSport. The selected variable
appears in the If Condition field.
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5. From the Operators, click =.
6. From the Operators, click ""Yes"".
* The If Condition field will read MissSport=(+)
7. Click Then. The tab selector appears. The Check Command Tree is not active.
8. TFrom the Fields tab, select GoTo. The GOTO dialog box opens.
9. Select SPTimes from the list of vatiables.

10. In the GOTO dialog box, click OK. The IF dialog box opens.

o x|
If Condition
MissSport= (+)
: 2]
nu?ilahle\_fariahles + | N | = | <| > | &l u | ( | )
I bt Ll j AND OR "Yes" "No" "Missing™
Then | I Eise !
GOTO SPTimes GOTO NIHome
Functions | OK |
Clear | Help Cancel |

11. Click Else. The dialog box disappears.
12. From the Fields tab, select GOTO. The GOTO dialog box opens.
13. Select [lIHome from the list of variables.
14. Click OK. The IF dialog box opens.
15. Click OK. The code appears in the Program Editor:
IF MissSport= (+) THEN
GOTO SPTimes

ELSE
GOTO IlIHome
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END
16. Click Save.

* Notice in the drop-down that the field MissSport now has an asterisk meaning there
is code associated with that field.
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Use the ASSIGN Command

To program a mathematical function, you must use the Program Editor. In the survey, you
have a field called Date of Birth and a field called Age. You are going to create Check Code

that will calculate and enter the age of the respondent based on the date of birth and the date
the survey was completed.

1.

8.

9.

From your View, click Program or select View>Check Code. The Program
Editor opens.

From the Choose Field Where Action Will Occur drop-down, select DOB. The
Check Command Tree opens.

= After is the default setting for when all actions will occur. The calculation needs to
run after you enter information into the Date of Birth field.

From the Variables tab or the Check Command Tree, click Assign. The
ASSIGN dialog box opens.

= To complete the code, use the Functions and Operators buttons and the keyboard to
type in the = Expression field.

From the Assign Variable drop-down, select Age.

* The calculated value appears in the Age field.

In the = Expression field, type the function YEARS.

= To see a list of all the available functions, click Functions.
Type, or click, the left parenthesis.

= Statements of a function must be enclosed in parentheses. Use the Operator buttons
or type them in from your keyboard.

From the Available Variables drop-down, select DOB.
Type a comma.

Type the survey date of 10/25/2005.

10. Type or click the right parenthesis.
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Assign Variable

Age j

= Expression

‘fears(DOB,10/25/2005)
K|

Available Variables + | .

r=[<|>|a]"](])

=

DOB
I J AND OR “Yes" “No" “Missing™

Functions | | OK

Clear

Help | Cancel

11. Click OK. The Check Code appears in the Program Editor.
»  ASSIGN Age=Years(DOB,10/25/2005)
12. Click Save in the Program Editor.

= Always save your Check Code. Codes will not update unless you save. The
Save feature will also inform you of any syntax errors that will affect the code
functionality.

=  Notice that DOB now has an asterisk next to it in the Choose Field Where
Action Will Occur drop-down menu. This signifies that the variable has
Check Code associated with it.

13. Click OK in the Check Commands window to return to the Make/Edit View
main page.

58




LESSON 2

Use the DIALOG Command

You are going to create Check Code that will provide a dialog box and added instructions for
the person entering data into the project survey. The DIALOG command provides
interaction with the data entry personnel from within a program. Dialogs can display
information, ask for and receive input, and offer lists for making choices.

In the survey, you have a variable called MissDays. This variable refers to the question "How
many days of school has your child missed due to asthmar" You want to make sure that any
half days are rounded up and counted as whole days during the data entry process. Using the
DIALOG command allows you to set a reminder to run during data entry. This will help to
ensure you get the most accurate count from your survey data and that all persons entering
data will be doing so based on the same set of rules.

1. From your View, click Program or select View>Check Code. The Program
Editor opens.

2. From the Choose Field Where Action Will Occur drop-down, select MissDays.
=  You want the action to occur after data is entered into this field.

3. From the User Interaction tab or the Check Command Ttree, select Dialog. The
DIALOG box opens.

—Dialog Type

f* Simplei { Get Variahle " List of Values

| oK |

Clear Help | Cancel |

4. In the Title field, type Missed Days.
* The Dialog Type radio button will be selected as Simple.

5. In the Prompt field, type Count any half days as one.

59



EPI INFO™ TUTORIAL

baoe X

Dialog Type
’75' Simple {~ Get Variable ™ List of Yalues
Title
|I'u'|issed Days
Prompt
Ijunt any half days as one.

1

| oK |

Clear Help | Cancel |

6. Click OK The code appears in the Program Editor.
DIALOG "Count any half days as one." TITLETEXT="Missed Days"
7. Click Save in the Program Editor.

= When you test your code in the next chapter on Enter Data the following dialog box
should appear once you enter data in the MissDays variable.

Missed Days

Count any half days as one.
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Skills Review

Place a checkmark by the answer to the following questions. Refer to Appendix D Skills Reviews
Answer Key for additional details and the answers.

1.

Check Code can run Before or After values are entered in a variable.

[ JTrue
[ |False

Using the Program Editor, you can create Check Code that will run across pages or
records.

[ JTrue
[ ]False

In the Check Command window, variables tagged with an X have Check Code associated
with them.

[ JTrue
[ ]False

Which Function is used to create an age variable?

[ JROUND

[ IYEARS

[ JTXTTONUM

How does the answer Yes appear in the Program Editor?
(G

16
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Lesson Complete!

WHAT YOU LEARNED

How to

* Navigate the Program Editor.

= Create a Skip Pattern using the IF/THEN commands.
= Use the ASSIGN Command.

= Use the YEARS function.

= Use the DIALOG command.
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Lesson3

Enter Data

SUMMARY

This lesson is an introduction to entering data from the Make View and Enter Data modules
of Epi Info™. In this lesson, you will learn how to enter data, navigate the survey you created
in Make View, and enter data for the sample survey provided. You will also learn how to
search for records from the Enter module. When you enter records in the survey, you are
populating the data table with information that will be used for later analyses.

In Lesson 1, you created an electronic version of the survey you will use to collect data to aid
in your asthma initiative project. In Lesson 2, you added Check Code to your survey to speed
the data entry process and to act as a quality control measure. In Lesson 3, you will begin
entering data about the students from the survey population. Data entered in this lesson will
be used to create statistics and develop a picture of the student body of the county for which
you are trying to get funds.

Time to complete: 1 hour Beginner

Getting Started with Enter Data

Overview of basic information to navigate the Enter Data module.
Enter Data to the Survey

Use the record information provided to enter data into the View you created. Verify your
Check Code works as intended.

Enter Data to the Sample Survey

Gives you the opportunity to view a complete survey with existing records. Enter data from
the surveys in Appendix C.

Find Records
Introduction to the Find feature. Practice lesson included.

Skills Review

Series of five review questions, based on the reading and hands-on activities in this lesson.

BEFORE YOU BEGIN

Complete Lesson 1 Make View: Create a Survey.

Complete Lesson 2 Make View: Check Code.
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Download the sample project Asthma Survey 2005.

WHAT YOU NEED

Asthma Survey.MDB- This is the project you created in Lessons 1 and 2.
Asthma Survey 2005.MDB- This is the provided dataset used in this Lesson and Lesson 4.
Appendix C Sample Parent School Asthma Pre-Intervention Surveys

Appendix D Skills Reviews Answer Key

FIVE GOALS

= Learn to navigate the Enter Data module.

* Enter 4 records in the View you created.

= Verify that the data entry conditions and Check Code functions.
* Troubleshoot your Check Code, if there are errors.

* Enter 2 records in the sample View and Data table provided. The sample view and data
table Asthma Survey 2005.MDB will be used in Lessons 4-10.
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Getting Started with Enter

The Enter Data module can be accessed by clicking Enter Data from the Epi Info™ main
page. You can also access Enter Data through the Make View module by selecting
File>Enter Data. Use the Enter Data module to enter information into the survey/view you
created in Make View. When you enter data into the view, you are populating the data table
inside your project (mdb). You can navigate from Make View to Enter to test your Check
Code and Tab Otder, but once you create a data table and start adding data, you cannot make
changes to field names or types in your view.

The Enter program displays the View you created in Make View, constructs your data table,
and controls the data entry process by using the settings and Check Code established in Make
View. From the Enter Data module, you will enter new data, modify existing data, or search
for records. The Find function allows records to be located based on a series of matched
variables. As you enter data, the cursor moves from field to field, page to page, and saves data.
Navigation is provided for New, Next, Previous, First, and Last records and through related
tables.
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The Enter Data Workspace

If you do not have the project Asthma Survey.MDB that was created in Lesson 1 and 2, you
can use the provided project titled Asthma Survey 2005.MDB. Use this project for a reference
as you read the navigation sections and then skip to Section 3: Enter Data in the Sample

Survey.

1. From the Epi Info™ main page, click Enter Data. The Enter window opens.

2. Select File>Open.

3. Open the project you created in Make View titled AsthmaSurvey. The Select a
Table dialog box opens.

4. Select the View PrelnterventionSurvey.

5. Click OK The Data Table dialog box opens.

6. Click OK to create a New Data Table. The New Data Table dialog box opens.

7. Click OK to keep the Data Table Name and Unique ID set as the default. The

Enter page opens with the view you made in Make View.
* Notice you are in Record 1 of 1 on Page 1 titled Personal Information.
* The Enter Page Panel displays a list of pages created in the project. Data entered into

a page is automatically saved; however, you should use the Save Data button or
File>Save after making changes to existing records.
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This is an example of the Enter Data workspace. The top of the page shows you are in the

Enter module.

al Infarmation
2 Medical Information
3 Asthma Symptoms

Mext
Save data
Mark record as deleted
Find

This is an example of the Enter Data
Page Panel

Notice that you can navigate entered
records by using the arrow buttons
at the bottom of the page. You are in
Record 1 of 1.

You can enter a new record by
clicking the New button or tabbing
through the record to the end of the
available fields.

Record
I 1 Mew Record
<= | < | = | 2= MustEnter

_[Of ]| Fi=_Edit options Help

Parent School Asthma Pre-Intervention Survey

Please answer all the questions below, whether or not your child has asthma.

School ID # | vl

Gender | -| child's Date of Bith [~ Age [

Phone Number | - -

Student ID # | Zip Code |

PS School # |

This is an example of the Enter main page. The left hand pane
shows that you are in the Enter module of Epi Info™ and are on
Page 1 called Personal Information.

The cursor is sitting in the Student ID # field where you created a
Code Table. Notice in the bottom left hand section of the screen,
the words Must Enter. When you tab to fields that contain Check
Code, the text in the left hand corner changes. For example, a
Required field will read Must Enter when you tab to it.

Navigating Enter Data

You cannot navigate through pages until data has been entered in the preceeding page or until
all required fields are filled. You can familiarize yourself with the workspace prior to adding
records. Keep the Enter module open to complete the next lesson.

Enter Data Main Page
File

Use the File menu to open, close, save, print, or exit. You can also compact your database
with the compact utility. This reduces the size of your database but does not affect your data.

Edit

Use the Edit menu to Find specific records or to delete records. Deletion removes the current
record from the project, and all records associated with it. It also marks the record as deleted
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in the database. You can exclude deleted records from your analyses. Click Undelete to
return the record to active status.

Options

Use the Options Menu to select the values of Yes/No vatiables. Variables can appear as
Yes/No or True/False. From Options, you can also maximize the size of your screen image
by selecting Full Screen.

Help
Use the Help Menu to view the online help.
Enter Data Page Panel

Use the Page Panel to navigate pages in your View. If you are entering data and have a
required field, you must enter information into that field before proceeding to the next page.
From the Enter Page Panel you can go to the next record, save data, delete a record, find a
record, or create a new record.

Use the navigation arrows at the bottom of the Enter Page Panel to move between records.
Single arrows move you one record forward or backward. Double arrows move you to the
first or last record.

Record
#01 Mew Record

{{lﬂ:l}l}}

Type a specific record number in the Record field and press Enter to go directly to a record.
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Enter Data into your View

Begin entering the four student records listed in the table on the following page. Tab through
each field to run the Check Code and to navigate through the survey. If you do not tab
through the survey, your check code will not run.

1. Verify that your Check Codes are functioning.

Is the Code Table you created between the variables for School Number and PS
School Number functioning?

Did the Age field populate after you tabbed out of the Date of Birth Field?

If your answer to Missed Sports is No, is the Number of Times variable skipped? Did
the cursor go to the following question? If the answer is Yes, did the cursor go to the
Number of Times variable?

Did the dialog box pop-up after you tabbed through the question regarding missed
days?

After entering all the records, use the arrow keys to navigate between records and
pages. Is the code functioning across records and pages?

2. Select File>Save.

Check Code Troubleshooting

If your Check Code did not function, you can close the Enter module and return to
Make View to verify the following. Use Lesson 2 on Check Code to verify your code
appears as coded.

® Verify your tab order. Coded fields must be in the proper order and on the
proper page to function. For example, does the Age field come after the Date of
Birth field in your tab order list? Are SpTimes and IllHome in the proper order?
On the same page?

* Did you Save all your Check Code in the Program Editor after it was created?
Open the Program Editor and verify that there is an asterisk next to the variable.

= Is your code applied to the cotrect field? Are your If/Then statements in the
proper order?

® Is your code syntax correct? You can verify this by placing the cursor inside the
code and clicking Save. Did the code turn green or red? Red means you have an
error in your code.

* Do your commands have END statements?
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Enter the following Student Records

Refer to the section on Check Code Troubleshooting if your codes do not work.

Student 1 Student 2 Student 3 Student 4

School ID Number A | School ID Number B | School ID Number C | School ID Number D
Student ID Number 1 | Student ID Number 2 | Student ID Number 3 | Student ID Number 4
Zip 12207 12084 12077 12059

Male Female Male Male

01/29/1994 08/19/1995 11/08/1995 07/28/1994
555-555-5555 444-444-4444 333-333-3333 222-222-2222
Asthma, Wheezing No Conditions Asthma, Bronchitis RAD

Yes, Medication No Yes, Medication Yes, Medication
October N/A September July

Wheeze 2 times each Never Wheeze, 3 to 6 times Wheeze, Never

week cach week Cough, 2 times each
Cough, 2 times each Cough, Every day but | week

week not all day

Missed 11 days Missed 0 days Missed 5 days Missed 3 days

Yes, Missed sports, 1
to 3 times a week

No, Did not miss
sports

Yes, Missed sports, 2
times a month

No, Did not miss
sports

Asthma in home=1

Asthma in home=0

Asthma in home=2

Asthma in home=1
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Enter Data into the Sample View

If you are working with the Asthma Survey project you created in Lesson 1 and 2, you are
going to change projects. The sample project contains an example of the entire survey created
in Make View with ten records already entered. The sample project Asthma Survey 2005 is
located in the EIHA Tutorial folder

If you already have Asthma Survey 2005 open, skip to Step 7.

You will be entering the data from the two attached surveys located in Appendix C.

1.

From the Enter Data menu, select File>Open. The Select a Table dialog box
opens.

. Click Change Project. The Select a Project window opens.

Locate the EIHA Tutorial folder and select the sample project Asthma Survey
2005.

Click Open. The Select a Table dialog box opens.
Select the View PrelnterventionSurvey.

Click OK. The project opens to the next new record, which is number 11. The
sample project contains ten previously entered records.

Use the surveys from Appendixc C Data Entry Surveys to add two additional records.
You should have twelve records at the end of this lesson.
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m;? = DEIIF"E Edit  Options  Help
1 n

Jull
2 Medical Information
3 Asthma Symptoms

ldertification

School 1D Number .I Studert ID
MNumber

—

Parent School Asthma Pre-Interventation Survey

Record

[ 41 MNewRecod

<<|< > | 2>

Nest
Save data Personal Infarmation
Mark record as deleted
= ap Code
Find
Child's Last Name | Child's First Name
Mew

Gender [ 5] Child's Date of Bith [ - Age [

Your Last Name | Your First Name

Relationship o Child Home Phone Number e

PS School Number Grade l_ Today's Date —

Coded
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Find Records

There are two ways to locate specific records in a large data table.
1. From the Record field located on the Enter Page panel.
= Type the number 3 into the Record number field.
*  Press Enter. Record 3 of 12 appears in the window.
2. Click Find from the Enter Page panel. The Find Record window opens.
* Use the Find feature to locate specific records in a large dataset to edit.

»  Select a variable to search, try Zip. An entry field appears. Enter the search criteria.
For this example, enter 12207. Click OK or press Enter.

" To open a Record from Find, double click the black arrow to the left of the results
row.

* Embedded text items in multiline and text fields can be found by searching for
*word*. This type of search is called a Wild Card Search. In a Wild Card search, the
asterisk is used to represent any letter or string of letters. For example, a search of
last names as with the field ChildLast could look like *jo*. This search would pull
names with the letters jo in the beginning or end of a word in the last name field, ie.
Jones, Johnson, Johns, etc.

*  Dates and numeric fields can be searched using less than or greater than values (<>).
=  OR can be used search for matches based on more than one critetia.
" ?can be used to search for a single unknown character.

* (lick Reset to clear the page and begin a new search.
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~ Practice
Find the students who attend School A.

Find the students who do not have bronchitis. Hint: Bronchitis NO.
Find the students who missed more than 5 days of school. Hint: MissDays>5.
Find the students who attend School A and have Asthma.

Find the students whose last name begins with S. Hint: ChildLast S*.
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Skills Review

Place a checkmark in the correct answer for each of the questions below. Refer to Appendix
D: Skills Review Question and Answer Sheet for further details.

1. Once you create a you cannot change field names or types in your view.
|:|Survey
[ ]Data Table
[ |Legal Value
2. What are the two ways you can enter a new record? Check all that apply.
[ ]Tab through to the last record.
[]Click New.
[ ]Select the last available page.

3. If you are entering data and have a required field, you must enter information into that
field before proceeding to the next page.

[ JTrue
[ ]False

4. What expression could you enter in the Find feature to locate children who are greater
than 6 in age?

[ ]Age=6
[ ]Age<6
[ ]Age>6

5. From the Find feature, what button do you click to clear the page and begin a new
search?

[ ]Start

[ JReset
[ ]Cancel
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Lesson Complete!

WHAT YOU LEARNED

How to

= Navigate Enter Data.
= Enter Records.

*  Change Projects.

®»  Find records.
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Lesson4

Analysis: Basics

SUMMARY

This lesson is an introduction to the Analysis module of Epi Info™. This lesson shows
different ways information can be viewed, based on selection inside Analysis.

In Lesson 3, you entered student data in a survey to collect information on asthma symptoms.
In Lesson 4, you will use the Analysis module to READ in that data and view it. Once
records are in Analysis, you can use several commands to SELECT, SORT, or LIST data that
can be included in the asthma report you want to create to apply for funding. Lesson 4 covers
these basic skills and shows you how to READ in data and Change Projects, which are
important skills you will use every time you open the Analysis module.

Length of time to complete: 1 hour Beginner
Getting Started with Analysis

Overview of basic information to navigate Analysis. Includes information about the Current
Project and Data Source settings. Use the READ Command to view the Asthma Survey 2005
Project.

Use the List Command

Use the LIST Command to view the variables in your dataset.

Use the Sort Command

Use the SORT Command to organize your data.

Use the Select Command

Use the SELECT Command to organize your data. Includes a practice lesson.
Skills Review

Series of five review questions based on the reading and hands-on activities in this lesson.

BEFORE YOU BEGIN

Complete Lesson 3 Enter Data
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WHAT YOU NEED

Asthma Survey 2005.MDB- If you have not completed Lesson 3, you can use the Asthma
Survey 2005.MDB project to complete this lesson as an introduction to Analysis; however,
you will have ten records rather than twelve.

Appendix D: Skills Reviews Answer Key

FIVE GOALS

= Understand and be able to use the READ/IMPORT command. This command is used
every time you open Analysis.

®  Use the LIST command to create a grid or web table and view the variables in your data
table.

®  Use the SORT command to view variables in a specified order.
®  Use the SELECT command to view requested variables.

* Beable to cancel a SELECT or a SORT and return to the original data count.
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Getting Started with Analysis

The Analysis module can be accessed by clicking Analyze Data from the Epi Info™ main
page. You can also select Programs>Analyze Data. Analysis can read data files created in
Make View and other types of databases such as DBase, FoxPro, MS Excel, and others.
Analysis can produce graphs and interact with Epi Map to display geographic data. Once you
have collected your data, Analysis acts as a statistical toolbox providing you with many ways
to transform you data and perform statistical evaluations. Analysis also provides you with
ways to export your data to new file formats such as MS Excel.

The Analysis module contains three working areas: the Analysis Command Tree, the Analysis
Output window, and the Program Editor.

1. The Analysis Command Tree contains a list of available commands separated into folders
by command type. The Command Tree is used to create the functions and programs that
run your statistics from the data. Selecting a command opens the corresponding dialog
box for that command, function, or statistic to run.

2. The Output window acts as a browser and displays all the information that is generated
from the commands run in the Program Editor. The Output window buttons allow you
to navigate through the program scripts that have been run and displayed in the output
screen.

3. The Program Editor displays the dialog/code of the commands created using the
Command Tree. Commands can be directly typed into the Program Editor. Programs or
PGM files written in Analysis are stored in the open .MDB. Programs can be saved and
run against new data when the data becomes available.
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The Analysis Workspace
Click Analyze Data or seclect Programs>Analyze Data to open the Analysis module.
This is an example of the Analyze Data workspace. The top of the page shows that you

are in the Analysis module. The Analysis module consists of three windows: the
Command Tree, the Output window, and the Program Editor.

o
w | | t[V[i]|e|=|s| & O

Previous [Wext |55t History Bookmark. Print Maximize.

= =
i Data Epi Info

Read [Import)

Relate

Write [Export)

Merge

Delete File/Table

Delete Records

Undelete Records
= Vanables

Define This is the Output window.

Undefine

Assign

Recode After you run a command, the results
h |Di:,':|lfy appear in this window.

elecl
Select
Cancel Select Once you Read in a file, the Output

i window shows your Current View and the
This is the Command Record Count for that View.

Tree for Analysis.

Commands are broken H
into folder groups.

Program Editor - New Program B

File Edit “ew Fonts Run Help

The Help button appears
at the bottom of the
window.

HNew | Open | Save | Print | Run | Run This Command |

This is the Program Editor window.
Commands generated from the
Command Tree wizards appear in
this window.

—Iﬂr’Ip 4 »
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Reading in a Project

Read this section and then Read/Import your survey data by completing the steps listed in
the next section.

In order to analyze data, you must Read or Import a project into the Analysis module. The
Read command allows you to select a project and data table on which to run your statistics.
The Read/Import command will be used every time you open the Analysis module in order
to begin work.

From the READ dialog box, you will select a project containing data for analyses. The
Current Project is the database file (MIDB) which is the default source of data. Output files
created from this data will be stored in this destination folder, unless otherwise specified. In
our project, the destination for Output files is the EIHA Tutorial folder.

Reap x|

<' current F'rujeﬁ N
‘I’&tEpi-_-hfu‘tElHn‘lﬁJrialmsthma Survey 2005.mdb

Data Formats
Epi 2000 |

< Data Source
IC:Epl_IﬁqulHn Tutorial'Asthma Survey 2005.mdb _|

—Show
{* \iews Al

Views
BaewPrelnterventionSurvey

< Change Project |> Save Only 0K

Clear | Help Cancel

It is recommended that the Current Project and the Data Source match. Having the same
Project and Data Source allows you to keep all your data and tables together. If they do not
match, click Change Project. The project you select will appear as the Current Project and
Data Source.

If you Read in a file where the Project and Source do not match, you will be asked to create a
linked table. Data sources other than the current project are accessed through link tables
located in the current project. Linked files are references to the data tables, and not the actual
data, so if you move your files to a new location, the links will be broken.
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From the Data Formats drop-down you will specify the data format for the data to be read
or written, for example MS Excel. From the Show section, you can select project Views or
All tables, views, and links for a project. When you click OK, the READ command will
be saved in the Program Editor and it will run the command at the same time. Save Only
allows you to save the command to the Program Editor only and does not run the READ
command.
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Read/Import an Epi Info™ Project

1.

From the Analysis Command Ttree, click Read (Import). The READ dialog box
opens.

Click Change Project. The READ File Name box opens.
Use the Look In drop-down menu to locate your C drive.
Open the Epi_Info folder.

Open the EIHA Tutorial folder.

Select the project Asthma Survey 2005. This is the project you added records to
from the Enter module in Lesson 3.

Click Open. The Current Project field and the Data Source field inside the
READ dialog box will populate.

Select the view PrelnterventionSurvey from the Show section.

Click OK. The Output window opens.

s R e
4 +|.l @

Previous || Hext Last History,

o

Bookmark

=

print

=

Maximize

~
=
Open

[ Analysis Commands =

& Data :
FEpi Info
Relate
Write [Export]
:ellgle T Current Fiew: C:\Epi_Info'ETHA Tutorial\Asthma Survey 2005.mdh:viewPreInterventionSurvey
Bt e Record Count: 13 (Delated recards excluded) Date: 412712005 11:57:35 AM
Undelete Records
= Variables
Define
Undefine
Assign
Recode
Display
(2 Select/If
Select
Cancel Select
If
Sort
Cancel Sort
= Statistics
List
Frequencies
Tables
Match

Means 5 =
= Program Editor - New Program ]
Summarize -

Graph Fil= Edit View Fonts Run Help

= Map Hew | Open ‘ Save | Print Run Run This Command
Advanced Stalistics

Linear Regression

Logistic Regression
Kaplan-Meier Survival

Cox Proportional Hazards
Complex Sample Frequencies
Complex Sample Tables
Complex Sample Means LI

FEAD 'C:\Epi InfotEIHAL Tutorial)isthma Survey
Z005.mdb' :vievPrelntervention3urvey

Help ,

*= The Output window shows your Current View from inside the EIHA
Tutorial folder.
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*  You should have a Record Count of 12.
* Notice the READ command you executed appears in the Program Editor.
Navigating Analysis

Read the following sections and familiarize yourself with the Analysis workspace. Click
Cancel or the close X to exit any dialog or command boxes you open.

Output Window

The Analysis Output window acts as a browser to display all the output information
that is generated from the commands created and run in the Program Editor. The
Output window buttons allow you to navigate through program scripts that have
been run and displayed including Previous, Next, Last, History, Open, Bookmark,
Print, and Maximize.

LR AEIR-

T

@%D‘

Previous ek Lask Hiskary Cpen Bookmark. Prink Mazxirnize:
Program Editor Menu
File

Use the File Menu to create New files, Open, Save, Close, Print, and Exit.
Edit

Use the Edit Menu to Copy, Paste, Delete, Find, Replace, or go to the Program
Beginning, and Program End.

View

Use the View Menu to place the Status Bar and/or the Tool Bar.
Fonts

Use the Fonts Menu to select Fonts, Style, and Color.

Run

Use the Run Menu to Run a Program or Run This Command to run one line of
code.
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Commands in this Lesson

The Command Tree contains a set of commands located in a seties of nine foldets.
READ/IMPORT

READ is the most commonly used command. The Read (Import) command changes the
current data source and/or the current project. It removes any standard defined variables.
The READ command operates on many different types of data. Epi Info™ can Read in 24
different types of files. Located in the Data folder.

SELECT

The Select command specifies a condition that must be true for a record to be processed. Use
to select a set of records for analyses. For example, select records based on gender or zip
code. Located in the Select/If folder.

CANCEL SELECT

The Cancel Select command cancels a previous SELECT command. Located in the Select/If
folder.

SORT

The Sort command specifies the sequence in which records will appear when using the LIST,
GRAPH, or WRITE commands. SORT organizes the listed data in an ascending or
descending order, based on selected variables. For example, you can sort by last name or age.
Located in the Select/If folder.

CANCEL SORT

The Cancel Sort command cancels a previous SORT command. Located in the Select/If
folder.

LIST

The List command creates a listing of the current data table. Lists can be customized to list all,
exclude, or show specific records. Located in the Statistics folder.
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Use the LIST Command

The LIST command creates a line listing of the current dataset. Select specific variables from
the Variables drop-down to narrow the list or select * (the Wild Card) to display all the
variables. Check the All (*) Except box and select from the Variables drop-down to exclude
variables from the list.

1. From the Command Tree Statistics folder, click List. The LIST dialog box

opens.
=
VYariahles
I =
[ Al (*) Except Display Mode
" Webh (HTML)
i+ Grid

" Allow Updates

Save Onhy OK

Clear Help Cancel

2. Click OK to accept the default settings. The variables in your dataset appear in a
grid table inside your Output Window.

= Notice the LIST command in the Program Editor.

*  Grid output is not embedded, so an Output file is not created.
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o R abeeowee BEE
SchoollD | StudentD | Zip Gender DDB Age Phone Yourl ast PSNumhel|DhiIdLasl |DhiIdFllsl |Y
A 1 12207 male 01-23-1934 11 555-555-656 | Smith 123 Smith Randy Cl
A 12210 female 10281937 7 456-783-123 Sulivan 123 Sullivan Brittany Bil
|= Analysis Commands ) 3 12208 male 0E-23-1935 9 456-378-459  Lewis 123 Lewis Beniji Ki
= Data ) 4 12183 male 0201-1936 9 896564548 Jones 123 Jones Lee Ri
Read (Import) & 1] 12110 male 04031334 11 156-489-456 | Michaels 123 Michaels | Steve T
Relate ) 3 12047 male 03131335 10 564-986-532 | Logan 123 Logan Ken Ji
Write [Export) ) 7 12202 male 07-21-1933 & 565784521 Fogers 123 Fiogers Aaron Ly
Merge & 8 12209 male 09121936 & 564-956-231 | Philips 123 Phillips Lary M,
Delete File/Table & 9 12209 male 09051997 |7 564-896-523 | Suttan 123 Suttan Brstt Ci
Delete Records ) 10 12208 male 12181935 9 789-456-156 Davidson 123 Davidson | Mark S
Undelete Records ) 1 12208 female 11-30-1934 10 555555555 Evans 123 Evans Katie R
[ Variables ) 12203 female 11081995 9 333-333-333 Williams 123 “williams Beth S
Define
Undefine
Assign
Recode
Display
= Select/If
Select
Cancel Select
If
Sort
Cancel Sort
[ Statistics
Frequencies
Tables =
Match
Means =
Summarize :
Graph File Edit “isw Fonts Run Help
Map . New ‘ Open | Save | Print | Run | Run This Command |
= Advanced Stalistics
Laost th diassn READ 'C:4\Epi InfoyEIHE TutoriallAistchma Survey :I
Logistic Regression 2005 . el iviswPrelntervent ionSurvey
Kaplan-Meier Survival ILIST * GRIDTAELE

Cox Proportional Hazards
Complex Sample Frequencies
Complex Sample Tables
Complex Sample Means LI

Help 7 _'l_l

Create a Web Format List
1. Click List. The LIST dialog box opens.

2. From the Display Mode section of the LIST box, select the radio button Web

3. Click OK. The List appears in the Output window in a web table format.
= Web display mode creates an embedded Output file.

* Notice the title bar now contains the name of your default output file.
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Use the Sort Command

The SORT command allows you to specify the sequence in which records will appear. If
more than one variable is selected, records are sorted in order by the first variable. After you
sort records, you must use the LIST command to see the results.

1.

2.

From the Command Ttree Select/If folder, click Sort. The SORT dialog box opens.
Double click the variable DOB to place it in the Sort Variables field.

*  Variables can be sorted by ascending or descending order.

Click OK.

* The Record Count stays at 12.

Use the LIST command to view all the variables. You can view the list in the format you
prefer, Grid or HTML.

»  Notice how the list is sorted based on the DOB variable.

Click Cancel Sort. The CANCEL SORT dialog opens.

Click OK.

*  Records remain sorted until you close Analysis, Read in a new project, or Cancel Sort.

= Notice the Sort information is listed in your Output window.

Current View: C:\Epi Info'ETHA Tutorial'Asthma Survey 2005.mdh: viewPreInterventionSurvey
Sart: DOR
Record Count: 12 (Deleied records excluded) Daie: 9714/2005 1:03:48 P

88



LESSON 4

Create a List of Sorted Variables
1. Click Sort. The SORT dialog box opens.

2. Double click the variable ChildLast to place it in the Sort Variables field.
3. Click OK.
4. Click List. The LIST dialog box opens.
5. Select Web (HTML) from the Display Mode.
6. From the Variables drop-down select
»  ChildFirst
*  ChildLast
= Asthmatic Conditions
7. Click OK The selected variables appear in a web table format.

* Notice the list is sorted alphabetically by the Child's Last Name variable.

C:Epi_Info*EIHA Tutorial\DUT144.htm
|V | 2 || & | B &|O
Previous [ext Last History Cpen Biookmark Prink Maximize
=
‘ Ch.l;? ajn Felrst Chil\? a:n iast ‘ Rea;:)til::a;ﬁs\:way e Asthmate P]g"::::ﬁl&:iss or Wheezy NN s
|Mark |Davidson |Yes |Yes |Yes |Yes
|Katie |Evans |Yes |Yes |Yes |Yes
|Lee |.Tones |No |Yes |Yes |Yes
|Benji |Lew1's |Yes |Yes |No |No
|Ken |Logan |No |Yes |Yes |No
|Steve |M.ichaels |No |Yes |Yes |Yes
|La.rry |Phj]]ips |Yes |Yes |Yes |Yes
|Aaron |Rogers |No |Yes |Yes |No
Randy Smith Mo Tes Mo Tes
|Brittany |Su]]ivan |Yes |Yes |Yes |Yes
|Brett |Sutton |Yes |Yes |No |Yes
|Beth |Williams |Yes |Yes |No |Yes

8. Click Cancel Sort. The CANCEL SORT dialog box opens.

9. Click OK. The original dataset order is applied.
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Use the Select Command

You can use the SELECT command to specify criteria for data to be included in Analysis
functions. Think about the various ways you could divide your data into groups using this
command. From the current data, you could select based on Age, Gender, Zip Code, or any
combination of vatiables, in addition to illness information.

Once you make a selection, it affects all the analyses that follows. You must use the Cancel
Select command to remove the selection. Selections accumulate until you Cancel Select, close
Analysis, or Read in a new project. Use the LIST Command to see the selected records.

From the sutvey, select only the male students' data.

1. From the Command Tree Select/If folder, click Select. The SELECT dialog box
opens.

2. TFrom the Available Variables drop-down, select Gender. Gender appears in the
Select Criteria field.

3. Click the = operator.

»

Click or type quote ".
5. Type the word Mate.

* The word Male must be enclosed in quotes because it is a text field. Text variables
must appear in quotes.

6. Click or type quote " to close the expression.

X

Select Criteria
Gender="male"

; 2

Available Variables + | =1 | = | <| > | &| g | ( | )
| Gender [ aND | OR | "ves" “No" | “Missing"
Functions | Save Only | oK |
Clear | Help | Cancel |

7. Click OK. The Output window updates with your new selection criteria.
= The Current View stays the same

»  The Select criteria appears as Gender="Male"
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* The Record Count changes to 9.

* The Program Editor contains the Select command information.

M =] 23} | Analysis Output
~
Exit ) ¥ 4| @ = | % & | O
Presyious Bext Last Histary OpeEn Bookmark, Erint. Maximize
| Analysis Commands = =
= Data g
Read [Import) Epl Info
Relate
Write (Export)
Merge Current View: C:\Epi_Info\EIHA Tutorial'Asthma Survey 2005.mdb: viewPreInterventionSurvey
Delete File/Table
Delete Records Select: Gender = “'male"
Undelete Records Record Count: 9 (Deleted records excluded) Date: 4/27/2005 12:08:05 PM
[ Variables
Define
Undefine
Assign
Recode
Display
= Select/It
Select
Cancel Select
It
Sort
Cancel Sort
[ Statistics
List
Frequencies
Tables L.
Match hd
Means -
Summarize
Graph File Edit “iew Fonts Run Help
Map Hew ‘ Open | Save ‘ Print | Run Run This Command
[ Advanced Statistics —
Linear Regression RELD 'C:4Epi_ Info\ETHA Tutorial)isthma Survey
Logistic Regression Z005.mih ' rviewPrelnterventionsurvey
Kaplan-Meier Survival
Cox Proportional Hazards SORT ChildLast
Complex Sample Frequencies LIST ChildFirst ChildLast AsthwaticConditions
Complex Sample Tables = =
Complex Sample Means ;I SELECT Gender="male
-
Help A _’l_l

List the Selected Records
1. Click List. The LIST Dialog box opens.

2. Select Web (HTML) as the Display Mode.
3. Click OK to view all the variables.

= Notice that all the records in the list are for male students.
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Select Based on Age

Remember the Select command has a cumulative affect on your data. Now select all the Male
students who are younger than the age of 9. You have already selected the male students.

1. Click Select. The SELECT dialog box opens.

2. TFrom the Available Variables drop-down, select Age.
3. Click or type <.

4. Type the number 9.

= The Select Criteria field should read Age<9.

SELecT x|
Select Criteria
Age<g
i 2
Available Variables -] =]<|>|&|"|(])
| Age [ anD | or | "ves" "No" | “Missing"
Functions | Save Only | | oK |
Clear | Help | Cancel |

5. Click OK. The Output window updates.
= Notice the Record Count is now 2.

* Notice that your Select criteria reads (Gender = "male") AND (Age < 9). This
expression could have been entered into the Select Criteria field at one time.

*  The expression SELECT Gender = "male" AND Age < 9 could have been typed
and Run directly from the Program Editor.

Current Fiew: C:\Epi InfolETHA Tutorial'Asthma Survey 2005.mdh: viewPreInterventionSurvey
Selantr (Gender = "male" ) AND (Age =9)
Feeord Count: 21 (Deleted records excluded) Dater 9714/2005 1:07:33 PM

6. List the records in a Web format.
7. Click Cancel Select.

= Notice the Record Count returns to the original 12.
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# Practice

Select the students who answered Yes to Bronchitis. (Hint: Bronchitis="+") You should get a
Record Count of 8.

Sort those 8 students by Age.
List the students in a web format.

Do not forget to Cancel Sort and Cancel Select to return to the original 12 records.
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Skills Review

Place a checkmark next to the correct answer for each of the following questions. Refer to
Appendixc D Skills Reviews Answer Key for further details.

1. After you run a command, the code appears in which window?
[ ]Output window
[ |Program Editor window
[ JCommand Tree
2. What command allows you to open a project for analysis?
[ JLIST
[ JREAD
[ JSELECT
3. What command would you use to see variables and records in the current data table?
[ JLIST
[ JSORT
[ JREAD
4. What command would you use to specify a sequence for records to appear?
[ |SORT
[ JLIST
[ JSELECT
5. What are the two Display Modes you can use with the LIST command?
[ Web (HTML)
[ ]Grid

[ IMS Word
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Lesson Complete!

WHAT YOU LEARNED

How to

= Use the LIST Command.

= Use the SORT Command.

= Use the SELECT Command.

= (Cancel and Sort or Select of records.

Read/Import an Epi Info™ project.
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This page intentionally blank.
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Lesson5

Analysis: Creating Statistics

SUMMARY

This lesson is an introduction to creating statistics using commands available in the Analysis
module. You will create results using the FREQUENCIES, MEANS, and TABLES
commands. Record your results on the Tear Out Answer Sheet provided. Verify your results

with the answers listed in Appendix E Lessons 5 Answer Key.

In Lesson 4, you used the READ command to view records entered in the survey during
Lesson 3. In Lesson 5, you will merge the 12 records from the Asthma Survey 2005.MDB
into records gathered and recorded in an MS Excel spreadsheet format. Many times
information needed for analyses will come from a vatiety of sources. In this example, you
have student records in an .MDB and in an MS Excel spreadsheet. You will use the MERGE
command to place all the student records in one project and then create statistics to see what
these records can tell you about asthma among the sampled student body.

Some of the things you are interested in discovering from the data is the frequency of asthma
among the students, the worst month for asthma among the students, and what is the average
number of missed days of school due to asthma. These types of data will be used to create the
report that illustrates the need for asthma initiative funding,

Length of time to complete: 2 hours Beginner
Commands in this Lesson

Brief explanation of the commands used in this lesson and the results produced by using
those commands.

Use the Display Command

Use the DISPLLAY command to view information about the variables in the project.
Use the Set Command

Use the SET command to generate viewing options for records and statistics.

Use the Merge Command

Use the MERGE command to join information from an MS Excel spreadsheet to an Epi
Info™ project file.

Use the Frequency Command

Use the FREQUENCY command to produce results based on a number of selected
occurrences. Includes a Practice Lesson.
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Skills Review

Use the SELECT command to create a Frequency for a subset of records.

Use the Means Command

Use the MEANS command to define an average.

Skills Review

Use the ASSIGN command to populate a field. Compute the MEANS of the new values.
Use the Tables Command

Use the TABLES command to produce results based on cross-tabulation of variables.
Includes a Practice Lesson.

Save a Program

Use the Program Editor to save and run the program created in this lesson.

BEFORE YOU BEGIN

Complete Lesson Four Analysis Basics

WHAT YOU NEED

Asthma Survey 2005.MDB
AsthmaTable.xls
Tear Out Q/A Sheet- Record your answets on this page.

Appendix E Lesson 5 Answer Key- Compare your answers to this page.

FIVE GOALS

®  Merge records from an Epi Info™ project file with an MS Excel file.

*  Use the FREQUENCY Command to discover which condition has the highest number
of affected students.

®  Use the MEANS Command to discover which school in the survey had the highest
average of missed school days due to breathing problems.

®  Use the TABLES Command to discover the odds and risk ratios for having wheezing
and asthma.

= Save a program (PGM) for use in a later lesson.
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Tear Out Q/A Sheet

Use this sheet to record your answers in the Answers column as you progress through the
Lesson 5. Answers are listed in Appendix E Lesson 5 Answer Key.

A.  Questions in Lesson 5 are marked with a letter.

Frequency Sections Answers

A.  Are there more males or females in the survey population?

B. Which condition has the highest frequency?

C. Which month had the highest number of students with
breathing difficulties?

D. Which school had the highest number of students with
bronchitis?

E. Which gender has the highest frequency of Asthma?

F.  How many students answered Yes to Reactive Airway Disease?

G. What is the percentage of students with Reactive Airway
Disease that have been prescribed medication?

H. Which zip code has the most surveyed students living in it?

| Of that zip code, which condition had the highest frequency?

J. How many students answered Yes to all four conditions:
Asthma, Reactive Airway Disease, Bronchitis, or Wheezing.

K. Based on all four conditions and zip code, are the conditions
evenly distributed among the survey population?

L. Does one school have more students in affected zip codes and
with all four conditions than the others do?

Means Sections Answers

M. What was the most frequent number of missed days?
N

What is the mean (average) number of days missed due to
asthmatic conditions?

O. Which school had the highest average of missed days?

P. Was the school with the highest average of missed days for
males the same as the school with the highest average of
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missed days for females?

Q. TIs the average number of missed days higher among those who
answered Yes to asthma than the overall average? Refer to
Question N.

R.  Whatis the average age of the student popul